summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorljurk2020-03-21 13:38:20 +0100
committerljurk2020-03-21 13:38:20 +0100
commit395d61a4c3458bfa8d3daef8b8155b72f7dfcd82 (patch)
treebd34e1bfdb5dfae3cc7c1d12fe53401cffa96eb9
parentaff73cf2827cbb157bef17565a858e8e9c88f900 (diff)
downloadaur-395d61a4c3458bfa8d3daef8b8155b72f7dfcd82.tar.gz
switch to gitlab and python version numbers
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aeca75725e2e..b88690eafc0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = python-jiramenu-git
pkgdesc = Dmenu/Rofi frontend for jira
- pkgver = r25.5997742
+ pkgver = r1.0.3
pkgrel = 1
- url = https://github.com/ljurk/jiramenu
+ url = https://gitlab.com/ljurk/jiramenu
arch = any
license = GPLv3
makedepends = git
+ makedepends = python
depends = python
optdepends = dmenu: either dmenu or rofi is required
optdepends = rofi: either dmenu or rofi is required
provides = python-jiramenu
conflicts = python-jiramenu
- source = git://github.com/ljurk/jiramenu.git
+ source = git+https://gitlab.com/ljurk/jiramenu.git
md5sums = SKIP
pkgname = python-jiramenu-git
diff --git a/PKGBUILD b/PKGBUILD
index e0e0c4d3ce25..a3d419c6f11f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,26 @@
_pkgname=python-jiramenu
_gitname=jiramenu
pkgname=$_pkgname-git
-pkgver=r25.5997742
+pkgver=r1.0.3
pkgrel=1
pkgdesc="Dmenu/Rofi frontend for jira"
arch=('any')
-url="https://github.com/ljurk/jiramenu"
+url="https://gitlab.com/ljurk/jiramenu"
license=('GPLv3')
depends=('python')
-makedepends=('git')
+makedepends=('git'
+ 'python')
optdepends=('dmenu: either dmenu or rofi is required'
'rofi: either dmenu or rofi is required')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git://github.com/ljurk/$_gitname.git")
+source=("git+https://gitlab.com/ljurk/$_gitname.git")
md5sums=('SKIP')
pkgver() {
cd "$_gitname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "r%s" "$(python setup.py --version)"
}
build() {
cd "$_gitname"