summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiu Zhe2018-09-10 12:48:25 +0800
committerLiu Zhe2018-09-10 12:48:25 +0800
commit8c46ee41f0c2b12b302c278e8b85d31b9d34260c (patch)
tree73149de603d9f11610d5b7578fa321fc0467ac47
downloadaur-8c46ee41f0c2b12b302c278e8b85d31b9d34260c.tar.gz
create
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..561a26324bf4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-json-tricks
+ pkgdesc = Extra features for Python's JSON
+ pkgver = 3.12.2
+ pkgrel = 1
+ url = https://github.com/mverleg/pyjson_tricks
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ optdepends = python-numpy
+ optdepends = python-pytz
+ optdepends = python-pandas
+ source = pyjson_tricks-3.12.2.tar.gz::https://github.com/mverleg/pyjson_tricks/archive/v3.12.2.tar.gz
+ sha1sums = 29537cb4a210dcbb6f6c130994b39730b64d831c
+
+pkgname = python-json-tricks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12367659d860
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Liu Zhe <cruise.pas@gmail.com>
+
+pkgname=python-json-tricks
+pkgver=3.12.2
+pkgrel=1
+pkgdesc="Extra features for Python's JSON"
+arch=('any')
+url='https://github.com/mverleg/pyjson_tricks'
+license=('BSD')
+depends=('python')
+optdepends=('python-numpy' 'python-pytz' 'python-pandas')
+makedepends=('python-setuptools')
+source=("pyjson_tricks-$pkgver.tar.gz::https://github.com/mverleg/pyjson_tricks/archive/v$pkgver.tar.gz")
+sha1sums=('29537cb4a210dcbb6f6c130994b39730b64d831c')
+
+build() {
+ cd "$srcdir"/pyjson_tricks-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/pyjson_tricks-$pkgver
+ python setup.py install --skip-build -O1 --root="$pkgdir"
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}