summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-09-26 01:57:55 -0500
committerLuis Martinez2021-09-26 01:57:55 -0500
commit172de4d7b3683dc57aabd95d9b1291c52832d01c (patch)
tree4e721aeadf4361d9b60bff74b79a9db5bcedd84a
parentcd38b7e5623399b9830526c1e015314af833c14a (diff)
downloadaur-172de4d7b3683dc57aabd95d9b1291c52832d01c.tar.gz
update to 0.6.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD47
2 files changed, 34 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e22efe38bdbb..488bf73e1339 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = python-jsonstreams
- pkgdesc = A Python module for writing JSON as a stream
- pkgver = 0.4.1
+ pkgdesc = Python module for writing JSON as a stream
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/dcbaker/jsonstreams
arch = any
license = MIT
+ checkdepends = python-pytest-runner
makedepends = python-setuptools
+ makedepends = python-sphinx
+ makedepends = python-sphinx_rtd_theme
+ depends = python-six
optdepends = python-simplejson
- options = !emptydirs
- source = https://pypi.python.org/packages/09/9b/21a1d63160166e58a4b2e24f068c1bf9bfb3610f389d39cd5e96910b4f47/jsonstreams-0.4.1.tar.gz
- source = https://pypi.python.org/packages/09/9b/21a1d63160166e58a4b2e24f068c1bf9bfb3610f389d39cd5e96910b4f47/jsonstreams-0.4.1.tar.gz.asc
- source = https://raw.githubusercontent.com/dcbaker/jsonstreams/master/LICENSE
+ source = python-jsonstreams-0.6.0.tar.gz::https://github.com/dcbaker/jsonstreams/archive/0.6.0.tar.gz
validpgpkeys = 5303CCAA8FFEE5A1472F3538089E1696140688EF
- sha256sums = 875c03c0a93e1e23a7eaa7a7a89e36290ff29613286bce563dad37fb7061addd
- sha256sums = SKIP
- sha256sums = 8b1cc8af45b502fd5bfce434721cb0d9a833298f05fe983ebc6c7f36d06fab59
+ sha256sums = 2ae77cf5db3f7a2c5e5a882594ef2cc0c160b4068cbb36389980f551c260b8a2
pkgname = python-jsonstreams
-
diff --git a/PKGBUILD b/PKGBUILD
index f051ab40daf7..756c71fe3218 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,38 @@
-# Maintainer: Dylan Baker <dylan@pnwbakers.com>
-_name=jsonstreams
-pkgname=python-${_name}
-pkgver=0.4.1
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Dylan Baker <dylan@pnwbakers.com>
+
+pkgname=python-jsonstreams
+pkgver=0.6.0
pkgrel=1
-pkgdesc="A Python module for writing JSON as a stream"
+pkgdesc='Python module for writing JSON as a stream'
arch=('any')
-url="https://github.com/dcbaker/jsonstreams"
+url='https://github.com/dcbaker/jsonstreams'
license=('MIT')
-depends=()
-makedepends=('python-setuptools')
+depends=('python-six')
optdepends=('python-simplejson')
-options=(!emptydirs)
-source=('https://pypi.python.org/packages/09/9b/21a1d63160166e58a4b2e24f068c1bf9bfb3610f389d39cd5e96910b4f47/jsonstreams-0.4.1.tar.gz'
- 'https://pypi.python.org/packages/09/9b/21a1d63160166e58a4b2e24f068c1bf9bfb3610f389d39cd5e96910b4f47/jsonstreams-0.4.1.tar.gz.asc'
- 'https://raw.githubusercontent.com/dcbaker/jsonstreams/master/LICENSE')
-sha256sums=('875c03c0a93e1e23a7eaa7a7a89e36290ff29613286bce563dad37fb7061addd'
- 'SKIP'
- '8b1cc8af45b502fd5bfce434721cb0d9a833298f05fe983ebc6c7f36d06fab59')
+makedepends=('python-setuptools' 'python-sphinx' 'python-sphinx_rtd_theme')
+checkdepends=('python-pytest-runner')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('2ae77cf5db3f7a2c5e5a882594ef2cc0c160b4068cbb36389980f551c260b8a2')
validpgpkeys=('5303CCAA8FFEE5A1472F3538089E1696140688EF') # Dylan Baker <dylan@pnwbakers.com>
-prepare() {
- cp LICENSE "$srcdir/${_name}-$pkgver"/
+build() {
+ cd "jsonstreams-$pkgver"
+ python setup.py build
+ cd docs
+ make man
}
-package() {
- cd "$srcdir/${_name}-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+check() {
+ cd "jsonstreams-$pkgver"
+ python setup.py pytest
+}
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+package() {
+ cd "jsonstreams-$pkgver"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 docs/build/man/jsonstreams.1 -t "$pkgdir/usr/share/man/man1/"
}
# vim:set ts=2 sw=2 et: