summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse R Codling2023-10-26 15:03:06 -0400
committerJesse R Codling2023-10-26 15:03:06 -0400
commit63d14ef1234108681971948c094ae16ae4172690 (patch)
tree32c0d28ffdb441e2e6a41d09bd2d88b4280ec160
downloadaur-63d14ef1234108681971948c094ae16ae4172690.tar.gz
Initial commit, generated by pip2pkgbuild
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0259f09ab7ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-jupyterlab-vim
+ pkgdesc = Code cell vim bindings for JupyterLab and Jupyter-Server
+ pkgver = 4.1.0
+ pkgrel = 1
+ url = https://jupyterlab-contrib.github.io/jupyterlab-vim.html
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-hatch-nodejs-version
+ makedepends = python-hatch-jupyter-builder
+ depends = python
+ depends = jupyter-lsp
+ depends = jupyter-collaboration
+ source = https://files.pythonhosted.org/packages/source/j/jupyterlab_vim/jupyterlab_vim-4.1.0.tar.gz
+ sha256sums = 11d850ee91b2864a7b6298aae465219a822f8ccc6e01f23fa03f1ee617afe330
+
+pkgname = python-jupyterlab-vim
+ depends = python
+ depends = jupyter-lsp
+ depends = jupyter-collaboration
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb722ed3d169
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jesse R Codling <codling@umich.edu>
+
+pkgbase='python-jupyterlab-vim'
+pkgname=('python-jupyterlab-vim')
+_module='jupyterlab_vim'
+pkgver='4.1.0'
+pkgrel=1
+pkgdesc="Code cell vim bindings for JupyterLab and Jupyter-Server"
+url="https://jupyterlab-contrib.github.io/jupyterlab-vim.html"
+depends=('python' 'jupyter-lsp' 'jupyter-collaboration')
+makedepends=('python-build' 'python-installer' 'python-hatch-nodejs-version' 'python-hatch-jupyter-builder')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/${_module/-/_}-$pkgver.tar.gz")
+sha256sums=('11d850ee91b2864a7b6298aae465219a822f8ccc6e01f23fa03f1ee617afe330')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/python-jupyterlab-vim/LICENSE"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+}