summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenzo Gaifas2022-07-01 16:13:12 +0200
committerLorenzo Gaifas2022-07-01 16:13:12 +0200
commit7e75883cc08ba8fd8782888103d2f549732f41f6 (patch)
treeea9c4ec64152508ab5ba2dd2973a46102910788e
parentaa986be02e6f99e42d13ec4495ca58edf3d0dd5b (diff)
downloadaur-7e75883cc08ba8fd8782888103d2f549732f41f6.tar.gz
v0.2.3
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD46
2 files changed, 51 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15aaa63094c4..97768e4dfacd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,26 @@
pkgbase = python-justpy
pkgdesc = An object oriented high-level Python Web Framework that requires no front-end programming
- pkgver = 0.1.4
- pkgrel = 3
+ pkgver = 0.2.3
+ pkgrel = 1
url = https://justpy.io/
arch = any
license = Apache
- makedepends = python-setuptools
- makedepends = cython
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-flit-core
depends = python
- depends = python-starlette
- depends = uvicorn
- depends = python-itsdangerous
- depends = python-jinja
depends = python-addict
- depends = python-demjson-git
- depends = python-httpx
depends = python-aiofiles
- source = justpy-0.1.4.tar.gz::https://github.com/elimintz/justpy/archive/v0.1.4.tar.gz
- sha512sums = 7572f8ea210357e13049229629394ac60fe44ec8772c2a65d99adaaa5bbd3b760eaff6acefad17a0c12e73744b0665878d81b2882d2757f8d98e7da13cb305d9
+ depends = python-demjson3
+ depends = python-httpx
+ depends = python-itsdangerous
+ depends = python-jinja
+ depends = python-starlette
+ depends = python-websockets
+ depends = uvicorn
+ provides = python-justpy
+ source = https://files.pythonhosted.org/packages/source/j/justpy/justpy-0.2.3.tar.gz
+ sha256sums = 8db66276af9c2e5c52a496b3ac111f77e5c4e0b259e71582e290bb2782a8c1ab
pkgname = python-justpy
-
diff --git a/PKGBUILD b/PKGBUILD
index be000fd8a7f6..87c75564f113 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,47 @@
# Maintainer: Lorenzo Gaifas <brisvag@gmail.com>
-pkgname=python-justpy
-pkgver=0.1.4
-pkgrel=3
+_name='justpy'
+_author='elimintz'
+_framework='python'
+pkgname="${_framework}-${_name}"
+pkgver=0.2.3
+pkgrel=1
pkgdesc="An object oriented high-level Python Web Framework that requires no front-end programming"
arch=('any')
license=('Apache')
url="https://justpy.io/"
-depends=('python' 'python-starlette' 'uvicorn' 'python-itsdangerous' 'python-jinja' 'python-addict' 'python-demjson-git' 'python-httpx' 'python-aiofiles')
-makedepends=('python-setuptools' 'cython')
-source=("justpy-$pkgver.tar.gz::https://github.com/elimintz/justpy/archive/v$pkgver.tar.gz")
-sha512sums=('7572f8ea210357e13049229629394ac60fe44ec8772c2a65d99adaaa5bbd3b760eaff6acefad17a0c12e73744b0665878d81b2882d2757f8d98e7da13cb305d9')
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
+ 'python-flit-core'
+)
+depends=(
+ 'python'
+ 'python-addict'
+ 'python-aiofiles'
+ 'python-demjson3'
+ 'python-httpx'
+ 'python-itsdangerous'
+ 'python-jinja'
+ 'python-starlette'
+ 'python-websockets'
+ 'uvicorn'
+)
+source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('8db66276af9c2e5c52a496b3ac111f77e5c4e0b259e71582e290bb2782a8c1ab')
+provides=("${_framework}-${_name}")
build() {
- cd $srcdir/justpy-$pkgver
- python setup.py build
+ cd "${srcdir}/${_name}-${pkgver}"
+ python -m build --wheel --no-isolation
}
package() {
- cd $srcdir/justpy-$pkgver
- python setup.py install --skip-build --prefix=/usr --root="$pkgdir" --optimize=1
+ cd "${srcdir}/${_name}-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+
+ install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}
+
+# vim:set ts=2 sw=2 et:<Paste>