summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenzo Gaifas2020-10-06 14:02:00 +0200
committerLorenzo Gaifas2020-10-06 14:02:00 +0200
commitde458896734d3fe955b9b80e106b975319cc95b9 (patch)
treebc4cb8528ff36143bb4808b47ea89720c4c1ff28
downloadaur-de458896734d3fe955b9b80e106b975319cc95b9.tar.gz
first commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD23
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac1cb9a3bfc5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-justpy
+ pkgdesc = An object oriented high-level Python Web Framework that requires no front-end programming
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://justpy.io/
+ arch = x86_64
+ license = Apache
+ makedepends = python-setuptools
+ makedepends = cython
+ depends = python
+ depends = python-starlette
+ depends = uvicorn
+ depends = python-itsdangerous
+ depends = python-jinja
+ depends = python-addict
+ depends = demjson
+ depends = python-httpx
+ depends = python-aiofiles
+ source = justpy-0.1.4.tar.gz::https://github.com/elimintz/justpy/archive/v0.1.4.tar.gz
+ sha512sums = 7572f8ea210357e13049229629394ac60fe44ec8772c2a65d99adaaa5bbd3b760eaff6acefad17a0c12e73744b0665878d81b2882d2757f8d98e7da13cb305d9
+
+pkgname = python-justpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d936b87d3cca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Lorenzo Gaifas <brisvag@gmail.com>
+
+pkgname=python-justpy
+pkgver=0.1.4
+pkgrel=1
+pkgdesc="An object oriented high-level Python Web Framework that requires no front-end programming"
+arch=('x86_64')
+license=('Apache')
+url="https://justpy.io/"
+depends=('python' 'python-starlette' 'uvicorn' 'python-itsdangerous' 'python-jinja' 'python-addict' 'demjson' 'python-httpx' 'python-aiofiles')
+makedepends=('python-setuptools' 'cython')
+source=("justpy-$pkgver.tar.gz::https://github.com/elimintz/justpy/archive/v$pkgver.tar.gz")
+sha512sums=('7572f8ea210357e13049229629394ac60fe44ec8772c2a65d99adaaa5bbd3b760eaff6acefad17a0c12e73744b0665878d81b2882d2757f8d98e7da13cb305d9')
+
+build() {
+ cd $srcdir/justpy-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/justpy-$pkgver
+ python setup.py install --skip-build --prefix=/usr --root="$pkgdir" --optimize=1
+}