summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAbdo Roig-Maranges2019-04-27 10:47:53 +0200
committerAbdo Roig-Maranges2019-04-27 10:48:30 +0200
commit24a1385f576c146f95fcce8afcff753b08d7d96c (patch)
treea1c5123ab9d9a1443ac442edc2c3db4c7c95487b
downloadaur-24a1385f576c146f95fcce8afcff753b08d7d96c.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..541202d79fb7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-jwcrypto
+ pkgdesc = Python implementation of JWK, JWS, JWE specifications
+ pkgver = 0.6
+ pkgrel = 1
+ url = https://github.com/latchset/jwcrypto
+ arch = any
+ license = LGPL3
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = jwcrypto::git+https://github.com/latchset/jwcrypto.git#commit=5d991eb808571ab463694ee1ec31b22c8b753c34
+ sha256sums = SKIP
+
+pkgname = python-jwcrypto
+ depends = python-cryptography
+
+pkgname = python2-jwcrypto
+ depends = python2-cryptography
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d7f963d1304
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Abdó Roig-Maranges <abdo.roig@gmail.com>
+
+_commit="5d991eb808571ab463694ee1ec31b22c8b753c34" # v0.6.0
+pkgbase="python-jwcrypto"
+pkgname=("python-jwcrypto" "python2-jwcrypto")
+pkgver="0.6"
+pkgrel=1
+pkgdesc="Python implementation of JWK, JWS, JWE specifications"
+arch=("any")
+url="https://github.com/latchset/jwcrypto"
+license=("LGPL3")
+makedepends=("python-setuptools" "python2-setuptools")
+source=("jwcrypto::git+https://github.com/latchset/jwcrypto.git#commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/jwcrypto"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/jwcrypto"
+ python setup.py build
+ python2 setup.py build
+}
+
+package_python-jwcrypto() {
+ depends=("python-cryptography")
+ cd "${srcdir}/jwcrypto"
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_python2-jwcrypto() {
+ depends=("python2-cryptography")
+ cd "${srcdir}/jwcrypto"
+ python2 setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}