summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2016-01-11 08:10:45 -0800
committerKyle Manna2016-01-11 08:33:33 -0800
commita602a98dbc77c4865419466828d7016e274cbe6c (patch)
tree9e1bb731bb3d1f0a44955b7d713f9250a7536220
parentfce98a748a9fa6b47021ca0d2ff417e55d8f1240 (diff)
downloadaur-a602a98dbc77c4865419466828d7016e274cbe6c.tar.gz
release: v0.5-4 continue fixing Python 3 issues
* Not sure that this works.
-rw-r--r--.SRCINFO4
-rw-r--r--0001-storage-Python-3-fix-for-izip.patch2
-rw-r--r--0002-storage-Python-3-fix-for-imap.patch2
-rw-r--r--0003-storage-Python-3-fix-for-zope.interface.patch37
-rw-r--r--PKGBUILD3
5 files changed, 43 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4438d4de9559..579bdfe2e3ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jan 11 16:28:10 UTC 2016
+# Mon Jan 11 16:33:16 UTC 2016
pkgbase = python-kademlia
pkgdesc = Distributed hash table for decentralized peer-to-peer computer networks
pkgver = 0.5
- pkgrel = 3
+ pkgrel = 4
url = http://github.com/bmuller/kademlia
arch = any
license = MIT
diff --git a/0001-storage-Python-3-fix-for-izip.patch b/0001-storage-Python-3-fix-for-izip.patch
index 68fbdc691fc6..eaf92509747b 100644
--- a/0001-storage-Python-3-fix-for-izip.patch
+++ b/0001-storage-Python-3-fix-for-izip.patch
@@ -1,7 +1,7 @@
From 2b8bc2209ef356feabf6cd60ab7abbc54a99018b Mon Sep 17 00:00:00 2001
From: Kyle Manna <kyle@kylemanna.com>
Date: Mon, 11 Jan 2016 08:23:16 -0800
-Subject: [PATCH 1/2] storage: Python 3 fix for izip
+Subject: [PATCH 1/3] storage: Python 3 fix for izip
* Work with both.
---
diff --git a/0002-storage-Python-3-fix-for-imap.patch b/0002-storage-Python-3-fix-for-imap.patch
index 7065504ae404..7b03f383d755 100644
--- a/0002-storage-Python-3-fix-for-imap.patch
+++ b/0002-storage-Python-3-fix-for-imap.patch
@@ -1,7 +1,7 @@
From c71a3700ac264cd62ac2e58cbab1a422d292f0a6 Mon Sep 17 00:00:00 2001
From: Kyle Manna <kyle@kylemanna.com>
Date: Mon, 11 Jan 2016 08:23:16 -0800
-Subject: [PATCH 2/2] storage: Python 3 fix for imap
+Subject: [PATCH 2/3] storage: Python 3 fix for imap
* Work with both.
---
diff --git a/0003-storage-Python-3-fix-for-zope.interface.patch b/0003-storage-Python-3-fix-for-zope.interface.patch
new file mode 100644
index 000000000000..b45e0bc66a51
--- /dev/null
+++ b/0003-storage-Python-3-fix-for-zope.interface.patch
@@ -0,0 +1,37 @@
+From e531f28468255d5559898e3c353dd514773aebfd Mon Sep 17 00:00:00 2001
+From: Kyle Manna <kyle@kylemanna.com>
+Date: Mon, 11 Jan 2016 08:23:16 -0800
+Subject: [PATCH 3/3] storage: Python 3 fix for zope.interface
+
+* Work with both.
+---
+ kademlia/storage.py | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/kademlia/storage.py b/kademlia/storage.py
+index 41610da..edfd0cf 100644
+--- a/kademlia/storage.py
++++ b/kademlia/storage.py
+@@ -13,7 +13,7 @@ from itertools import takewhile
+ import operator
+ from collections import OrderedDict
+
+-from zope.interface import implements
++from zope.interface import implementer
+ from zope.interface import Interface
+
+
+@@ -47,9 +47,8 @@ class IStorage(Interface):
+ Get the iterator for this storage, should yield tuple of (key, value)
+ """
+
+-
++@implementer(IStorage)
+ class ForgetfulStorage(object):
+- implements(IStorage)
+
+ def __init__(self, ttl=604800):
+ """
+--
+2.7.0
+
diff --git a/PKGBUILD b/PKGBUILD
index ab8f4eabfcd5..402b16868ead 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-kademlia
_pkgname=${pkgname/python-/}
pkgver=0.5
-pkgrel=3
+pkgrel=4
pkgdesc="Distributed hash table for decentralized peer-to-peer computer networks"
url="http://github.com/bmuller/kademlia"
depends=('python' 'python-twisted' 'python-rpcudp')
@@ -16,6 +16,7 @@ build() {
cd "$srcdir/$_pkgname-$pkgver"
patch -p1 < "$srcdir/../0001-storage-Python-3-fix-for-izip.patch"
patch -p1 < "$srcdir/../0002-storage-Python-3-fix-for-imap.patch"
+ patch -p1 < "$srcdir/../0003-storage-Python-3-fix-for-zope.interface.patch"
python setup.py build
}