summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgnebbia2020-09-25 23:02:10 +0200
committergnebbia2020-09-25 23:02:10 +0200
commitc8e46e9bea48125b9eca3159712827f6c2e67324 (patch)
treea781408c372e23c0956f712dfbf7a528e996814e
downloadaur-c8e46e9bea48125b9eca3159712827f6c2e67324.tar.gz
Pushed python-kb git version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9aec8974369
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-kb-git
+ pkgdesc = A command line minimalist knowledge base manager
+ pkgver = r28.b7b449e
+ pkgrel = 1
+ url = https://github.com/gnebbia/kb.git
+ arch = any
+ license = GPL3
+ makedepends = git
+ provides = python-kb-git
+ conflicts = python-kb-git
+ conflicts = python-kb
+ conflicts = kb
+ source = git+https://github.com/gnebbia/kb.git
+ md5sums = SKIP
+
+pkgname = python-kb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..981677918913
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Giuseppe Nebbione <nebbionegiuseppe at gmail dot com>
+
+pkgname=python-kb-git
+_reponame="kb"
+pkgver=r100.b6b334f
+pkgrel=1
+pkgdesc="A command line minimalist knowledge base manager"
+arch=(any)
+url="https://github.com/gnebbia/kb.git"
+license=('GPL3')
+depends=()
+makedepends=('git')
+provides=("python-kb-git")
+conflicts=("python-kb-git" "python-kb" "kb")
+source=("git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_reponame}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${_reponame}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+