summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid McInnis2018-06-14 05:36:40 -0700
committerDavid McInnis2018-06-14 05:36:40 -0700
commit2c3fbf3234d9a81cc854fa3626e02f6959a4691d (patch)
tree6e929824b78e58cdbfbd4e05b857d2e689797b70
parent1961514b15764c41913a91c78306b6f254ecc7bd (diff)
downloadaur-2c3fbf3234d9a81cc854fa3626e02f6959a4691d.tar.gz
added optdepends array
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5ac37f15426..bb9c7990ce5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-keras
pkgdesc = Deep Learning library (convnets, recurrent neural networks, and more)
pkgver = 2.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/fchollet/keras
arch = any
license = MIT
@@ -17,6 +17,10 @@ pkgbase = python-keras
makedepends = python2-scipy
makedepends = python2-h5py
makedepends = python2-yaml
+ optdepends = python-keras-preprocessing: Utilities for working with image data, text data, and sequence data.
+ optdepends = python-keras-applications: Reference implementations of popular deep learning models.
+ optdepends = python2-keras-preprocessing
+ optdepends = python2-keras-applications
source = keras-2.2.0.tar.gz::https://github.com/fchollet/keras/archive/2.2.0.tar.gz
sha256sums = 83eae0c251c5ec7e9134e6e79d81da58bfce88e6932fef69dd57c0d512d548f4
diff --git a/PKGBUILD b/PKGBUILD
index f7f59d9d51e8..56164cb7290f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase="python-keras"
pkgname=("python-keras" "python2-keras")
_pkgname="keras"
pkgver="2.2.0"
-pkgrel="1"
+pkgrel="2"
pkgdesc="Deep Learning library (convnets, recurrent neural networks, and more)"
arch=('any')
url="https://github.com/fchollet/keras"
@@ -13,6 +13,10 @@ license=('MIT')
makedepends=('python' 'python-setuptools' 'python-numpy' 'python-scipy' 'python-h5py' 'python-yaml'
'python2' 'python2-setuptools' 'python2-numpy' 'python2-scipy' 'python2-h5py' 'python2-yaml'
)
+optdepends=('python-keras-preprocessing: Utilities for working with image data, text data, and sequence data.'
+ 'python-keras-applications: Reference implementations of popular deep learning models.'
+ 'python2-keras-preprocessing' 'python2-keras-applications'
+ )
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/fchollet/${_pkgname}/archive/${pkgver}.tar.gz")
sha256sums=('83eae0c251c5ec7e9134e6e79d81da58bfce88e6932fef69dd57c0d512d548f4')