summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid McInnis2018-07-30 08:07:17 -0700
committerDavid McInnis2018-07-30 08:07:17 -0700
commit83ebcef7d8218d41248b18147332deb1fdde39e2 (patch)
tree35401177adcf2124901396cca7db2a7d7c7039d7
parent8a0bcd6d81323f94b3751b7308314425626844e2 (diff)
downloadaur-83ebcef7d8218d41248b18147332deb1fdde39e2.tar.gz
moved keras-applications and keras-preprocessing into optdepends with a must install message so user knows they need to install
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c9caa5ea5d6..ae47e1385fd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-keras
pkgdesc = Deep Learning library (convnets, recurrent neural networks, and more)
pkgver = 2.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/fchollet/keras
arch = any
license = MIT
@@ -31,6 +31,8 @@ pkgname = python-keras
optdepends = python-theano
optdepends = python-tensorflow
optdepends = cudnn
+ optdepends = python-keras-applications: Must Install for python-keras to work!
+ optdepends = python-keras-preprocessing: Must Install for python-keras to work!
pkgname = python2-keras
depends = python2
@@ -40,4 +42,6 @@ pkgname = python2-keras
depends = python2-yaml
optdepends = python2-theano
optdepends = cudnn
+ optdepends = python2-keras-applications: Must Install for python2-keras to work!
+ optdepends = python2-keras-preprocessing: Must Install for python2-keras to work!
diff --git a/PKGBUILD b/PKGBUILD
index 84d8f83d9b5e..2fdf3965dba7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase="python-keras"
pkgname=("python-keras" "python2-keras")
_pkgname="keras"
pkgver="2.2.2"
-pkgrel=1
+pkgrel=2
pkgdesc="Deep Learning library (convnets, recurrent neural networks, and more)"
arch=('any')
url="https://github.com/fchollet/keras"
@@ -40,7 +40,9 @@ build() {
package_python2-keras() {
depends=('python2' 'python2-numpy' 'python2-scipy' 'python2-h5py' 'python2-yaml')
- optdepends=('python2-theano' 'cudnn')
+ optdepends=('python2-theano' 'cudnn'
+ 'python2-keras-applications: Must Install for python2-keras to work!'
+ 'python2-keras-preprocessing: Must Install for python2-keras to work!')
cd "$srcdir/${_pkgname}-${pkgver}-py2"
python2 setup.py install --root="$pkgdir"/ --optimize=1
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
@@ -48,7 +50,9 @@ package_python2-keras() {
package_python-keras() {
depends=('python' 'python-numpy' 'python-scipy' 'python-h5py' 'python-yaml')
- optdepends=('python-theano' 'python-tensorflow' 'cudnn')
+ optdepends=('python-theano' 'python-tensorflow' 'cudnn'
+ 'python-keras-applications: Must Install for python-keras to work!'
+ 'python-keras-preprocessing: Must Install for python-keras to work!')
cd "$srcdir/${_pkgname}-${pkgver}"
python setup.py install --root="$pkgdir"/ --optimize=1
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"