summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid McInnis2017-11-03 21:50:59 -0700
committerDavid McInnis2017-11-03 21:50:59 -0700
commit8cb7bdca5d91026cb1d785e9d2ae8fb69007559c (patch)
tree81bed0ff21f9773b6ff32c59e161a2beb187da08
parentb9cb8c2e81fdb197f6782e5f41233bbfe8881e06 (diff)
downloadaur-8cb7bdca5d91026cb1d785e9d2ae8fb69007559c.tar.gz
added tensorflow to makedepends so people have fewer errors importing modules
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b41a053262e7..1ff504410430 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-keras
pkgdesc = Deep Learning library (convnets, recurrent neural networks, and more)
pkgver = 2.0.9
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/fchollet/keras
arch = any
license = MIT
@@ -11,12 +11,14 @@ pkgbase = python-keras
makedepends = python-scipy
makedepends = python-h5py
makedepends = python-yaml
+ makedepends = python-tensorflow
makedepends = python2
makedepends = python2-setuptools
makedepends = python2-numpy
makedepends = python2-scipy
makedepends = python2-h5py
makedepends = python2-yaml
+ makedepends = python2-tensorflow
source = keras-2.0.9.tar.gz::https://github.com/fchollet/keras/archive/2.0.9.tar.gz
sha256sums = cb572783074aa0252fc89dc849483652e569158da7438bd2fc1a090d9cd95f83
diff --git a/PKGBUILD b/PKGBUILD
index 1c3c6fae766c..cbd1d762b7f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@ pkgbase="python-keras"
pkgname=("python-keras" "python2-keras")
_pkgname="keras"
pkgver="2.0.9"
-pkgrel="1"
+pkgrel="2"
pkgdesc="Deep Learning library (convnets, recurrent neural networks, and more)"
arch=('any')
url="https://github.com/fchollet/keras"
license=('MIT')
-makedepends=('python' 'python-setuptools' 'python-numpy' 'python-scipy' 'python-h5py' 'python-yaml'
- 'python2' 'python2-setuptools' 'python2-numpy' 'python2-scipy' 'python2-h5py' 'python2-yaml'
+makedepends=('python' 'python-setuptools' 'python-numpy' 'python-scipy' 'python-h5py' 'python-yaml' 'python-tensorflow'
+ 'python2' 'python2-setuptools' 'python2-numpy' 'python2-scipy' 'python2-h5py' 'python2-yaml' 'python2-tensorflow'
)
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/fchollet/${_pkgname}/archive/${pkgver}.tar.gz")
sha256sums=('cb572783074aa0252fc89dc849483652e569158da7438bd2fc1a090d9cd95f83')