summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid McInnis2018-06-14 05:44:17 -0700
committerDavid McInnis2018-06-14 05:44:17 -0700
commit977c13131128a358fd9c93c9458a5ec2dede4887 (patch)
treef567e0eae45b7985423388ba9259fe79fb1d3664
parentb2fc13e4a8b6c59c1047c5cf3724dad4f2d73c14 (diff)
downloadaur-977c13131128a358fd9c93c9458a5ec2dede4887.tar.gz
added optdepends array
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f45b578ac53..2953cec03f34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-keras
pkgdesc = Deep Learning library (convnets, recurrent neural networks, and more)
pkgver = 2.2.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/fchollet/keras
arch = any
license = MIT
@@ -17,8 +17,8 @@ pkgbase = python-keras
makedepends = python2-scipy
makedepends = python2-h5py
makedepends = python2-yaml
- optdepends = python-keras-preprocessing: Utilities for working with image data, text data, and sequence data
- optdepends = python-keras-applications: Reference implementations of popular deep learning models
+ optdepends = python-keras-preprocessing: Utilities for working with image data, text data, and sequence data.
+ optdepends = python-keras-applications: Reference implementations of popular deep learning models.
optdepends = python2-keras-preprocessing
optdepends = python2-keras-applications
source = keras-2.2.0.tar.gz::https://github.com/fchollet/keras/archive/2.2.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 65a62fb87460..cfc6dc711bf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,18 @@ pkgbase="python-keras"
pkgname=("python-keras" "python2-keras")
_pkgname="keras"
pkgver="2.2.0"
-pkgrel="3"
+pkgrel="4"
pkgdesc="Deep Learning library (convnets, recurrent neural networks, and more)"
arch=('any')
url="https://github.com/fchollet/keras"
license=('MIT')
-makedepends=('python' 'python-setuptools' 'python-numpy' 'python-scipy' 'python-h5py' 'python-yaml' 'python2' 'python2-setuptools' 'python2-numpy' 'python2-scipy' 'python2-h5py' 'python2-yaml')
-optdepends=('python-keras-preprocessing: Utilities for working with image data, text data, and sequence data' 'python-keras-applications: Reference implementations of popular deep learning models' 'python2-keras-preprocessing' 'python2-keras-applications')
+makedepends=('python' 'python-setuptools' 'python-numpy' 'python-scipy' 'python-h5py' 'python-yaml'
+ 'python2' 'python2-setuptools' 'python2-numpy' 'python2-scipy' 'python2-h5py' 'python2-yaml'
+ )
+optdepends=('python-keras-preprocessing: Utilities for working with image data, text data, and sequence data.'
+ 'python-keras-applications: Reference implementations of popular deep learning models.'
+ 'python2-keras-preprocessing' 'python2-keras-applications'
+ )
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/fchollet/${_pkgname}/archive/${pkgver}.tar.gz")
sha256sums=('83eae0c251c5ec7e9134e6e79d81da58bfce88e6932fef69dd57c0d512d548f4')