summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabien Dubosson2017-03-14 23:29:28 +0100
committerFabien Dubosson2017-03-14 23:29:28 +0100
commitb99af35b63835ddbff1861a0503c003b32dd0e94 (patch)
tree0816f92b5ca74155db50bf0810b463c49ee4dbfa
parent07676db8bf73061ef451ec261ea801a135e20a04 (diff)
downloadaur-b99af35b63835ddbff1861a0503c003b32dd0e94.tar.gz
New upstream release 2.0.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD12
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d552991aec8a..722d9305565e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Feb 11 18:52:32 UTC 2017
+# Tue Mar 14 22:28:23 UTC 2017
pkgbase = python-keras
- pkgdesc = Theano-based Deep Learning library (convnets, recurrent neural networks, and more)
- pkgver = 1.2.2
+ pkgdesc = Deep Learning library (convnets, recurrent neural networks, and more)
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/fchollet/keras
arch = any
@@ -17,20 +17,21 @@ pkgbase = python-keras
makedepends = python2-numpy
makedepends = python2-scipy
makedepends = python2-h5py
- source = keras-1.2.2.tar.gz::https://github.com/fchollet/keras/archive/1.2.2.tar.gz
- sha256sums = 786f7a98a09c1217e7c76c2fb485440c3675c7188bf7d9afcd4e5c75fc97406e
+ source = keras-2.0.0.tar.gz::https://github.com/fchollet/keras/archive/2.0.0.tar.gz
+ sha256sums = 1cfe5c298be813a512549f993e4d4fdfe0f887a8e67f7bf915fda6089ac9d403
pkgname = python-keras
depends = python
depends = python-numpy
depends = python-scipy
- depends = python-theano
depends = python-h5py
+ optdepends = python-theano
+ optdepends = python-tensorflow
pkgname = python2-keras
depends = python2
depends = python2-numpy
depends = python2-scipy
- depends = python2-theano
depends = python2-h5py
+ optdepends = python2-theano
diff --git a/PKGBUILD b/PKGBUILD
index e0418f584e2c..86606046b67c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
pkgbase="python-keras"
pkgname=("python-keras" "python2-keras")
_pkgname="keras"
-pkgver="1.2.2"
+pkgver="2.0.0"
pkgrel="1"
-pkgdesc="Theano-based Deep Learning library (convnets, recurrent neural networks, and more)"
+pkgdesc="Deep Learning library (convnets, recurrent neural networks, and more)"
arch=('any')
url="https://github.com/fchollet/keras"
license=('MIT')
@@ -14,7 +14,7 @@ makedepends=('python' 'python-setuptools' 'python-numpy' 'python-scipy' 'python-
'python2' 'python2-setuptools' 'python2-numpy' 'python2-scipy' 'python2-h5py'
)
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/fchollet/${_pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('786f7a98a09c1217e7c76c2fb485440c3675c7188bf7d9afcd4e5c75fc97406e')
+sha256sums=('1cfe5c298be813a512549f993e4d4fdfe0f887a8e67f7bf915fda6089ac9d403')
prepare() {
cd "$srcdir/"
@@ -37,14 +37,16 @@ build() {
}
package_python2-keras() {
- depends=('python2' 'python2-numpy' 'python2-scipy' 'python2-theano' 'python2-h5py')
+ depends=('python2' 'python2-numpy' 'python2-scipy' 'python2-h5py')
+ optdepends=('python2-theano')
cd "$srcdir/${_pkgname}-${pkgver}-py2"
python2 setup.py install --root="$pkgdir"/ --optimize=1
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
}
package_python-keras() {
- depends=('python' 'python-numpy' 'python-scipy' 'python-theano' 'python-h5py')
+ depends=('python' 'python-numpy' 'python-scipy' 'python-h5py')
+ optdepends=('python-theano' 'python-tensorflow')
cd "$srcdir/${_pkgname}-${pkgver}"
python setup.py install --root="$pkgdir"/ --optimize=1
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"