summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid McInnis2018-07-29 00:25:59 -0700
committerDavid McInnis2018-07-29 00:25:59 -0700
commitdfddb361796f29e2ef4800090e2c9b97fe78d287 (patch)
tree23ca6553c5e8faa1e64f058584dbeb46140fa911
parent42da1b360ee48f86d4f4bbea6f836b46fca2aaa1 (diff)
downloadaur-dfddb361796f29e2ef4800090e2c9b97fe78d287.tar.gz
moved python-keras-applications and python-keras-preprocessing from optdepends into makedepends based on advice from the community
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c11b3756b78..b67b253b34db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-keras
pkgdesc = Deep Learning library (convnets, recurrent neural networks, and more)
pkgver = 2.2.0
- pkgrel = 7
+ pkgrel = 8
url = https://github.com/fchollet/keras
arch = any
license = MIT
@@ -10,15 +10,15 @@ pkgbase = python-keras
makedepends = python-scipy
makedepends = python-h5py
makedepends = python-yaml
+ makedepends = python-keras-applications
+ makedepends = python-keras-preprocessing
makedepends = python2-setuptools
makedepends = python2-numpy
makedepends = python2-scipy
makedepends = python2-h5py
makedepends = python2-yaml
- optdepends = python-keras-preprocessing: Utilities for working with image data, text data, and sequence data.
- optdepends = python-keras-applications: Reference implementations of popular deep learning models.
- optdepends = python2-keras-preprocessing
- optdepends = python2-keras-applications
+ makedepends = python2-keras-applications
+ makedepends = python2-keras-preprocessing
source = keras-2.2.0.tar.gz::https://github.com/fchollet/keras/archive/2.2.0.tar.gz
sha256sums = 83eae0c251c5ec7e9134e6e79d81da58bfce88e6932fef69dd57c0d512d548f4
diff --git a/PKGBUILD b/PKGBUILD
index bb5d193ffbb5..5260456fe401 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,18 +5,16 @@ pkgbase="python-keras"
pkgname=("python-keras" "python2-keras")
_pkgname="keras"
pkgver="2.2.0"
-pkgrel=7
+pkgrel=8
pkgdesc="Deep Learning library (convnets, recurrent neural networks, and more)"
arch=('any')
url="https://github.com/fchollet/keras"
license=('MIT')
makedepends=('python-setuptools' 'python-numpy' 'python-scipy' 'python-h5py' 'python-yaml'
+ 'python-keras-applications' 'python-keras-preprocessing'
'python2-setuptools' 'python2-numpy' 'python2-scipy' 'python2-h5py' 'python2-yaml'
+ 'python2-keras-applications' 'python2-keras-preprocessing'
)
-optdepends=('python-keras-preprocessing: Utilities for working with image data, text data, and sequence data.'
- 'python-keras-applications: Reference implementations of popular deep learning models.'
- 'python2-keras-preprocessing' 'python2-keras-applications'
- )
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/fchollet/${_pkgname}/archive/${pkgver}.tar.gz")
sha256sums=('83eae0c251c5ec7e9134e6e79d81da58bfce88e6932fef69dd57c0d512d548f4')