summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-06-18 23:53:31 +0200
committerMarcell Meszaros2022-06-18 23:53:31 +0200
commit40d32ea72291fd9c51f9289ce3820ea7f9f9f70a (patch)
tree03fd86a2d7c6622393002cb6596069bca69228ca
parentb3d963beae9ded9e865cf3e50902d01db39d8a33 (diff)
downloadaur-40d32ea72291fd9c51f9289ce3820ea7f9f9f70a.tar.gz
cleanup: formatting style
-rw-r--r--PKGBUILD67
1 files changed, 41 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c52479f51fd..37dab42172b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,76 @@
# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: Fabien Dubosson <fabien.dubosson@gmail.com>
-pkgbase="python-keras-git"
-pkgname=("python-keras-git" "python2-keras-git")
-_pkgname="keras"
+pkgbase='python-keras-git'
+pkgname=('python-keras-git' 'python2-keras-git')
+_pkgname='keras'
pkgver=1.2.0.r106.ge54d7951
pkgrel=1
-pkgdesc="Theano-based Deep Learning library (convnets, recurrent neural networks, and more)"
+pkgdesc='Theano-based Deep Learning library (convnets, recurrent neural networks, and more)'
arch=('i686' 'x86_64')
-url="https://github.com/fchollet/keras"
+url="https://github.com/fchollet/${_pkgname}"
license=('MIT')
-makedepends=('git'
- 'python' 'python-setuptools'
- 'python2' 'python2-setuptools'
- )
+makedepends=(
+ 'git'
+ 'python'
+ 'python-setuptools'
+ 'python2'
+ 'python2-setuptools'
+)
source=("${_pkgname}::git+http://github.com/fchollet/${_pkgname}.git")
sha256sums=('SKIP')
pkgver() {
- cd "$_pkgname"
+ cd "${_pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/"
+ cd "${srcdir}"
cp -a "${_pkgname}" "${_pkgname}-py2"
cd "${_pkgname}"
- sed -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
- -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
- -e "s|#![ ]*/bin/env python$|#!/usr/bin/env python2|" \
+ sed -e 's|#![ ]*/usr/bin/python$|#!/usr/bin/python2|' \
+ -e 's|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|' \
+ -e 's|#![ ]*/bin/env python$|#!/usr/bin/env python2|' \
-i $(find . -name '*.py')
}
build() {
- msg "Building Python 2"
- cd "$srcdir/${_pkgname}-py2"
+ msg 'Building Python 2'
+ cd "${srcdir}/${_pkgname}-py2"
python2 setup.py build
- msg "Building Python 3"
- cd "$srcdir/${_pkgname}"
+ msg 'Building Python 3'
+ cd "${srcdir}/${_pkgname}"
python setup.py build
}
package_python2-keras-git() {
- depends=('python2' 'python2-numpy' 'python2-scipy' 'python2-theano' 'python2-h5py')
+ depends=(
+ 'python2'
+ 'python2-numpy'
+ 'python2-scipy'
+ 'python2-theano'
+ 'python2-h5py'
+ )
provides=('python2-keras')
conflicts=('python2-keras')
- cd "$srcdir/${_pkgname}-py2"
- python2 setup.py install --root="$pkgdir"/ --optimize=1
+
+ cd "${srcdir}/${_pkgname}-py2"
+ python2 setup.py install --root="${pkgdir}"/ --optimize=1
}
package_python-keras-git() {
- depends=('python' 'python-numpy' 'python-scipy' 'python-theano' 'python-h5py')
+ depends=(
+ 'python'
+ 'python-numpy'
+ 'python-scipy'
+ 'python-theano'
+ 'python-h5py'
+ )
provides=('python-keras')
conflicts=('python-keras')
- cd "$srcdir/${_pkgname}"
- python setup.py install --root="$pkgdir"/ --optimize=1
-}
-# vim:set ts=2 sw=2 et:
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --root="${pkgdir}"/ --optimize=1
+}