summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjörn Bidar2022-09-08 04:36:24 +0300
committerBjörn Bidar2022-09-08 04:36:24 +0300
commit168ed48a990a9fc2366318869110a317976a57e1 (patch)
tree209ec71ae7d222f1779a84431435119cd2cf8425
downloadaur-168ed48a990a9fc2366318869110a317976a57e1.tar.gz
Intitial packaging
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36d851704257
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Sep 8 01:36:17 UTC 2022
+pkgbase = python-keyring-pass
+ pkgdesc = https://www.passwordstore.org backend for keyring
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/nazarewk/keyring_pass
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-keyring
+ depends = pass
+ source = git+https://github.com/nazarewk/keyring_pass#tag=v0.7.0
+ sha512sums = SKIP
+
+pkgname = python-keyring-pass
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca0dcfac91e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=python-keyring-pass
+_pkgname=keyring_pass
+pkgver=0.7.0
+pkgrel=1
+pkgdesc='https://www.passwordstore.org backend for keyring'
+arch=('any')
+url='https://github.com/nazarewk/keyring_pass'
+license=('MIT')
+depends=('python-keyring' 'pass')
+makedepends=('git' 'python-setuptools')
+source=("git+$url#tag=v$pkgver")
+sha512sums=('SKIP')
+
+
+build() {
+ cd $_pkgname
+ python setup.py build
+}
+
+package() {
+ cd $_pkgname
+ python setup.py install --root="$pkgdir" \
+ --optimize=1 \
+ --skip-build
+ install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: