summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2017-12-01 11:09:02 -0500
committerAdam Goldsmith2017-12-01 11:09:02 -0500
commite248dad16d1ef4cc2ac52585221722d7aaf7f089 (patch)
tree08322655ea136bc011f1b37ac23057e0429e0c04
downloadaur-e248dad16d1ef4cc2ac52585221722d7aaf7f089.tar.gz
Initial Commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af43885f237d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Dec 1 16:07:09 UTC 2017
+pkgbase = python-kiss
+ pkgdesc = A Python Module that implementations the KISS Protocol for communicating with KISS-enabled devices (such as Serial or TCP TNCs).
+ pkgver = 6.5.0
+ pkgrel = 1
+ url = https://github.com/ampledata/kiss
+ arch = any
+ license = Apache
+ depends = python
+ depends = python-pyserial
+ source = https://files.pythonhosted.org/packages/source/k/kiss/kiss-6.5.0.tar.gz
+ md5sums = 04acf4d8fe50d9150d19ead55a25c015
+
+pkgname = python-kiss
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5cc87af4bb3c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.pkg.*
+/kiss-*.tar.gz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..756f04d66fe0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+
+pkgname=python-kiss
+_pkgname=kiss
+pkgver=6.5.0
+pkgrel=1
+pkgdesc="A Python Module that implementations the KISS Protocol for communicating with KISS-enabled devices (such as Serial or TCP TNCs)."
+arch=('any')
+url="https://github.com/ampledata/kiss"
+license=('Apache')
+depends=(python python-pyserial)
+source=("https://files.pythonhosted.org/packages/source/k/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('04acf4d8fe50d9150d19ead55a25c015')
+
+package() {
+ cd $_pkgname-$pkgver/
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: