summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn ShaggyTwoDope Jenkins2015-06-23 01:36:43 -0700
committerSean Anderson2018-07-15 10:07:31 -0400
commit69c1ca39951ab0bc8f5e2a31f9602436e569a830 (patch)
treef7a110467f77f446e6c746b25b1823c9d472ef25
parent1cbd6c13e42944a0720ef3b49a5d64fc7c9c2d58 (diff)
downloadaur-69c1ca39951ab0bc8f5e2a31f9602436e569a830.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
2 files changed, 22 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 211b68186105..1c0cb56b03c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
-pkgbase = python-kitchen
- pkgdesc = Kitchen contains a cornucopia of useful code
- pkgver = 1.1.1
- pkgrel = 2
+pkgbase = python3-kitchen
+ pkgdesc = Useful snippets of python code
+ pkgver = 1.2.1
+ pkgrel = 1
url = https://fedorahosted.org/kitchen
arch = any
license = LGPLv2+
- makedepends = python2
- depends = python2
- provides = python2-kitchen
- conflicts = python2-kitchen
- source = https://pypi.python.org/packages/source/k/kitchen/kitchen-1.1.1.tar.gz
- md5sums = 059d7ce048ca1d0fb53e6755145137b0
-
-pkgname = python-kitchen
+ makedepends = python
+ depends = python
+ source = https://github.com/fedora-infra/kitchen/archive/1.2.1.tar.gz
+ md5sums = 654de4eba96b8bbf30ec7bd213b67921
+pkgname = python3-kitchen
diff --git a/PKGBUILD b/PKGBUILD
index 33313ed8807c..00ba7ab47283 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
-#Automatically generated by pip2arch on 2014-04-28
+#Maintainer: John Jenkins twodopeshaggy@gmail.com
-pkgname=python-kitchen
-pkgver=1.1.1
-pkgrel=2
-pkgdesc="Kitchen contains a cornucopia of useful code"
+pkgname=python3-kitchen
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="Useful snippets of python code"
url="https://fedorahosted.org/kitchen"
-depends=('python2' )
-makedepends=('python2')
+depends=('python' )
+makedepends=('python')
license=('LGPLv2+')
arch=('any')
-source=('https://pypi.python.org/packages/source/k/kitchen/kitchen-1.1.1.tar.gz')
-md5sums=('059d7ce048ca1d0fb53e6755145137b0')
-provides=(python2-kitchen)
-conflicts=(python2-kitchen)
+source=(https://github.com/fedora-infra/kitchen/archive/$pkgver.tar.gz)
+md5sums=('654de4eba96b8bbf30ec7bd213b67921')
build() {
- cd $srcdir/kitchen-1.1.1
- python2 setup.py build
+ cd $srcdir/kitchen-$pkgver
+ python setup.py build
}
package() {
- cd $srcdir/kitchen-1.1.1
- python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd $srcdir/kitchen-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}