summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Lewis2025-03-02 12:03:23 +1000
committerSamuel Lewis2025-03-02 12:03:23 +1000
commit7391e893cf887013589eb825d2324f79bd9e6968 (patch)
tree00dd7d3c34ebcbaf88cbd6c4d5f52423d121fb87
parentce82d1fb27c45251ea5f10e27ce7418b5b63ca9c (diff)
downloadaur-7391e893cf887013589eb825d2324f79bd9e6968.tar.gz
update to 1.2.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bbcceb605b4..23a68426b76a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = python-kivymd
pkgdesc = KivyMD is a collection of Material Design compliant widgets for use with Kivy, a framework for cross-platform, touch-enabled graphical applications.
- pkgver = 1.1.1
+ pkgver = 1.2.0
pkgrel = 1
- url = https://github.com/kivymd/KivyMD/
+ url = https://pypi.org/project/kivymd/
arch = any
license = MIT
makedepends = python-setuptools
- source = https://github.com/kivymd/KivyMD/archive/1.1.1.tar.gz
- md5sums = ba3c7e9696ac850e1c054af55a7da3f7
+ source = https://files.pythonhosted.org/packages/20/81/0b1154f5e581d5910702d9fadb3217f56cb186f72c8b36de0271e7ff9b5c/kivymd-1.2.0.tar.gz
+ md5sums = 1898379f722f5be9c2e5187cc9507853
pkgname = python-kivymd
diff --git a/PKGBUILD b/PKGBUILD
index 96e10f48688c..4d6e703ba23c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: EnderPi <samueltlewis27 at gmail.com>
# Contributor: lazant <a.l.i.c.e at outlook.com>
pkgname=python-kivymd
-pkgver=1.1.1
+pkgver=1.2.0
pkgrel=1
pkgdesc="KivyMD is a collection of Material Design compliant widgets for use with Kivy, a framework for cross-platform, touch-enabled graphical applications."
arch=('any')
-url="https://github.com/kivymd/KivyMD/"
+url="https://pypi.org/project/kivymd/"
license=('MIT')
makedepends=('python-setuptools')
-source=("https://github.com/kivymd/KivyMD/archive/${pkgver}.tar.gz")
-md5sums=('ba3c7e9696ac850e1c054af55a7da3f7')
+source=("https://files.pythonhosted.org/packages/20/81/0b1154f5e581d5910702d9fadb3217f56cb186f72c8b36de0271e7ff9b5c/kivymd-${pkgver}.tar.gz")
+md5sums=('1898379f722f5be9c2e5187cc9507853')
build() {
- cd "${srcdir}/KivyMD-${pkgver}"
+ cd "${srcdir}/kivymd-${pkgver}"
python setup.py build
}
package() {
- cd "${srcdir}/KivyMD-${pkgver}"
+ cd "${srcdir}/kivymd-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}