summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlazant2017-05-23 15:14:24 +0900
committerlazant2017-05-23 15:14:24 +0900
commite94320b79bba5ec9ed5710550fe94a554b4305c9 (patch)
treef835f4c71e040f1d7c2253b74e954d027be5fa5d
downloadaur-e94320b79bba5ec9ed5710550fe94a554b4305c9.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD32
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..421c144e0986
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Tue May 23 06:13:36 UTC 2017
+pkgbase = python-kivymd
+ pkgdesc = Set of widgets for Kivy inspired by Google's Material Design.
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://gitlab.com/kivymd/KivyMD/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = python-kivymd::https://pypi.python.org/packages/f1/2e/4bec1d1f1d004f54cd00b4013702de9815922df89bc05b562499a9bc1b9d/kivymd-0.1.2.tar.gz
+ source = LICENSE
+ md5sums = 51bbfb26c19f5010735d5e7213f73626
+ md5sums = 0e7641c066a04ca2c7c7502026d0fb3e
+
+pkgname = python-kivymd
+ depends = python-kivy
+
+pkgname = python2-kivymd
+ depends = python2-kivy
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..a17ea136196b
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2015 Andrés Rodríguez and KivyMD contributors
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..202e81b29400
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: lazant <a.l.i.c.e at outlook.com>
+pkgbase=python-kivymd
+pkgname=('python-kivymd' 'python2-kivymd')
+pkgdesc="Set of widgets for Kivy inspired by Google's Material Design."
+pkgver=0.1.2
+pkgrel=1
+arch=('any')
+url="https://gitlab.com/kivymd/KivyMD/"
+license=('MIT')
+source=("$pkgname::https://pypi.python.org/packages/f1/2e/4bec1d1f1d004f54cd00b4013702de9815922df89bc05b562499a9bc1b9d/kivymd-$pkgver.tar.gz"
+ "LICENSE")
+makedepends=('python-setuptools' 'python2-setuptools')
+md5sums=('51bbfb26c19f5010735d5e7213f73626'
+ '0e7641c066a04ca2c7c7502026d0fb3e')
+
+prepare() {
+ cp -a kivymd-$pkgver{,-python2}
+}
+
+package_python2-kivymd() {
+ depends=('python2-kivy')
+ cd "$srcdir/kivymd-$pkgver-python2"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 "$srcdir/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_python-kivymd() {
+ depends=('python-kivy')
+ cd "$srcdir/kivymd-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 "$srcdir/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}