summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReal-Gecko2022-10-25 17:17:46 +0500
committerReal-Gecko2022-10-25 17:17:46 +0500
commit66aa21768b387ce44191c74f17413127fc643cf9 (patch)
tree81441992dd47ce963c35376684599559d34b5627
downloadaur-66aa21768b387ce44191c74f17413127fc643cf9.tar.gz
2.0.6
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore6
-rw-r--r--LICENSE1
-rw-r--r--PKGBUILD143
-rw-r--r--PKGBUILD_EXTRAS0
5 files changed, 176 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..011e68cb69e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = python-kolo
+ pkgdesc = See everything happening in your running Django app
+ pkgver = 2.0.6
+ pkgrel = 00
+ url = https://kolo.app
+ arch = any
+ license = custom:© Kolo
+ makedepends = python-pip
+ depends = python
+ depends = python-cerberus
+ depends = python-click
+ depends = python-tomli
+ depends = python-toolz
+ depends = python-ulid-py
+ depends = python-django
+ depends = python-black
+ depends = python-jinja
+ noextract = kolo-2.0.6-py3-none-any.whl
+ source = PKGBUILD_EXTRAS
+ source = https://files.pythonhosted.org/packages/49/51/cdaf16dd545ed1e6a26cb716e0b745b6e8a0cd264eda9fb38e36fb976fbb/kolo-2.0.6-py3-none-any.whl
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = 14bfc7cee283866cae219b6b43eb1f53
+ md5sums = 72a73656a0823dab58aae967ffb09b63
+
+pkgname = python-kolo
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5869147911d1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!.gitignore
+!.SRCINFO
+!LICENSE
+!PKGBUILD
+!PKGBUILD_EXTRAS
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c637f419e8df
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1 @@
+LICENSE: custom:© Kolo
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c23cc6702e47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,143 @@
+# Maintainer: Unknown Packager
+
+export PIP_CONFIG_FILE=/dev/null
+export PIP_DISABLE_PIP_VERSION_CHECK=true
+
+pkgname=python-kolo
+epoch=
+pkgver=2.0.6
+pkgrel=00
+pkgdesc='See everything happening in your running Django app'
+arch=(any)
+url=https://kolo.app
+license=('custom:© Kolo')
+depends=(python python-cerberus python-click python-tomli python-toolz python-ulid-py)
+depends+=(python-django python-black python-jinja)
+makedepends=(python-pip)
+checkdepends=()
+provides=()
+conflicts=(${provides%=*}) # No quotes, to avoid an empty entry.
+source=(PKGBUILD_EXTRAS)
+md5sums=(SKIP)
+noextract=()
+source+=(https://files.pythonhosted.org/packages/49/51/cdaf16dd545ed1e6a26cb716e0b745b6e8a0cd264eda9fb38e36fb976fbb/kolo-2.0.6-py3-none-any.whl)
+md5sums+=(14bfc7cee283866cae219b6b43eb1f53)
+noextract+=(kolo-2.0.6-py3-none-any.whl)
+source+=(LICENSE)
+md5sums+=(72a73656a0823dab58aae967ffb09b63)
+
+_first_source() {
+ echo " ${source_i686[@]} ${source_x86_64[@]} ${source[@]}" |
+ tr ' ' '\n' | grep -Pv '^(PKGBUILD_EXTRAS)?$' | head -1
+}
+
+_vcs="$(grep -Po '^[a-z]+(?=\+)' <<< "$(_first_source)")"
+if [[ "$_vcs" ]]; then
+ makedepends+=("$(pkgfile --quiet /usr/bin/$_vcs)")
+ provides+=("${pkgname%-$_vcs}")
+ conflicts+=("${pkgname%-$_vcs}")
+fi
+
+_is_wheel() {
+ [[ $(_first_source) =~ \.whl$ ]]
+}
+
+if [[ _is_wheel &&
+ $(basename "$(_first_source)" | rev | cut -d- -f1 | rev) =~ ^manylinux ]]; then
+ options=(!strip) # https://github.com/pypa/manylinux/issues/119
+fi
+
+_dist_name() {
+ find "$srcdir" -mindepth 1 -maxdepth 1 -type d -printf '%f
+' |
+ grep -v '^_tmpenv$'
+}
+
+if [[ $(_first_source) =~ ^git+ ]]; then
+ _pkgver() {
+ ( set -o pipefail
+ cd "$srcdir/$(_dist_name)"
+ git describe --long --tags 2>/dev/null |
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+ }
+
+ pkgver() { _pkgver; }
+fi
+
+_build() {
+ if _is_wheel; then return; fi
+ cd "$srcdir"
+ # See Arch Wiki/PKGBUILD/license.
+ # Get the first filename that matches.
+ local test_name
+ if [[ ${license[0]} =~ ^(BSD|MIT|ZLIB|Python)$ ]]; then
+ for test_name in LICENSE LICENSE.txt license.txt COPYING COPYING.md COPYING.rst COPYING.txt COPYRIGHT; do
+ if cp "$srcdir/$(_dist_name)/$test_name" "$srcdir/LICENSE" 2>/dev/null; then
+ break
+ fi
+ done
+ fi
+ # Use the latest version of pip, as Arch's version is historically out of
+ # date(!) and newer versions do fix bugs (sometimes).
+ python -mvenv --clear --system-site-packages _tmpenv
+ _tmpenv/bin/pip --quiet install -U pip
+ # Build the wheel (which we allow to fail) only after fetching the license.
+ # In order to isolate from ~/.pydistutils.cfg, we need to set $HOME to a
+ # temporary directory, and thus first $XDG_CACHE_HOME back to its real
+ # location, so that pip inserts the wheel in the wheel cache. We cannot
+ # use --global-option=--no-user-cfg instead because that fully disables
+ # wheels, causing a from-source build of build dependencies such as
+ # numpy/scipy.
+ XDG_CACHE_HOME="${XDG_CACHE_HOME:-"$HOME/.cache"}" HOME=_tmpenv \
+ _tmpenv/bin/pip wheel -v --no-deps --wheel-dir="$srcdir" \
+ "./$(_dist_name)" || true
+}
+
+build() { _build; }
+
+_check() {
+ # Define check(), possibly using _check as a helper, to run the tests.
+ # You may need to call `python setup.py build_ext -i` first.
+ if _is_wheel; then return; fi
+ cd "$srcdir/$(_dist_name)"
+ /usr/bin/python setup.py -q test
+}
+
+_package() {
+ cd "$srcdir"
+ # pypa/pip#3063: pip always checks for a globally installed version.
+ python -mvenv --clear --system-site-packages _tmpenv
+ _tmpenv/bin/pip install --prefix="$pkgdir/usr" \
+ --no-deps --ignore-installed --no-warn-script-location \
+ "$(ls ./*.whl 2>/dev/null || echo ./"$(_dist_name)")"
+ if [[ -d "$pkgdir/usr/bin" ]]; then # Fix entry points.
+ python="#!$(readlink -f _tmpenv)/bin/python"
+ for f in "$pkgdir/usr/bin/"*; do
+ # Like [[ "$(head -n1 "$f")" = "#!$(readlink -f _tmpenv)/bin/python" ]]
+ # but without bash warning on null bytes in "$f" (if it is actually
+ # a compiled executable, not an entry point).
+ if python -c 'import os, sys; sys.exit(not open(sys.argv[1], "rb").read().startswith(os.fsencode(sys.argv[2]) + b"\n"))' "$f" "$python"; then
+ sed -i '1c#!/usr/bin/python' "$f"
+ fi
+ done
+ fi
+ if [[ -d "$pkgdir/usr/etc" ]]; then
+ mv "$pkgdir/usr/etc" "$pkgdir/etc"
+ fi
+ if [[ -f LICENSE ]]; then
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ fi
+}
+
+package() { _package; }
+
+. "$(dirname "$BASH_SOURCE")/PKGBUILD_EXTRAS"
+
+# Remove makedepends already in depends (which may have been listed for the
+# first build, but autodetected on the second.
+makedepends=($(printf '%s\n' "${makedepends[@]}" |
+ grep -Pwv "^($(IFS='|'; echo "${depends[*]}"))$"))
+: # Apparently ending with makedepends assignment sometimes fails.
diff --git a/PKGBUILD_EXTRAS b/PKGBUILD_EXTRAS
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/PKGBUILD_EXTRAS