summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorotaj2023-02-16 12:53:12 +0100
committerotaj2023-02-16 12:53:12 +0100
commit55fd139b93e3979351d9db28aae9f3e3e1b17354 (patch)
tree6cd7510b46a304c02119b729379a00e823d7e677
parentd946c35ddae7cbdd86447562129b2a5d88b35d2f (diff)
downloadaur-55fd139b93e3979351d9db28aae9f3e3e1b17354.tar.gz
chore
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9cdbb46b2c0..077503c40c15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-kornia
pkgdesc = Open Source Differentiable Computer Vision Library for PyTorch
- pkgver = 0.6.8
+ pkgver = 0.6.9
pkgrel = 1
url = https://github.com/kornia/kornia
arch = any
@@ -16,8 +16,9 @@ pkgbase = python-kornia
makedepends = python-wheel
makedepends = python-pytest-runner
depends = python-pytorch
+ optdepends = python-accelerate: To be able to train
options = !emptydirs
- source = kornia-0.6.8.zip::https://github.com/kornia/kornia/archive/refs/tags/v0.6.8.zip
- sha256sums = 61949be65328ee5da8562bc453c2989c009fab34ac57a430a8304d1834b5ba5e
+ source = kornia-0.6.9.zip::https://github.com/kornia/kornia/archive/refs/tags/v0.6.9.zip
+ sha256sums = 8186c470cb9f8cbec1e87da4c87e97fe5a113e785aab392c055aa21ac98385ec
pkgname = python-kornia
diff --git a/PKGBUILD b/PKGBUILD
index e46911f8d667..f5685f56edb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ TEST_GPU=0
pkgname=python-kornia
_name=kornia
-pkgver=0.6.8
+pkgver=0.6.9
pkgrel=1
arch=(any)
url='https://github.com/kornia/kornia'
@@ -12,11 +12,12 @@ pkgdesc='Open Source Differentiable Computer Vision Library for PyTorch'
license=(Apache)
makedepends=('python-build' 'python-installer' 'python-wheel' 'python-pytest-runner')
depends=('python-pytorch')
+optdepends=('python-accelerate: To be able to train')
checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-mypy' 'python-pytest-flake8' 'python-scipy' 'python-opencv')
options=(!emptydirs)
# because kornia does not ship `pytest.ini` with their release, we have to get a fat copy of full repo
source=("${_name}-${pkgver}.zip::${url}/archive/refs/tags/v${pkgver}.zip")
-sha256sums=('61949be65328ee5da8562bc453c2989c009fab34ac57a430a8304d1834b5ba5e')
+sha256sums=('8186c470cb9f8cbec1e87da4c87e97fe5a113e785aab392c055aa21ac98385ec')
build() {
cd "${srcdir}/${_name}-${pkgver}"
@@ -25,9 +26,9 @@ build() {
check() {
cd "${srcdir}/${_name}-${pkgver}"
- make test-cpu
+ pytest -v --device cpu --dtype float32,float64 --cov=kornia test/
if ! [ "$TEST_GPU" -eq "0" ] ; then
- make test-cuda
+ pytest -v --device cuda --dtype all --cov=kornia test/
fi
}