summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorotaj2022-10-24 16:28:51 +0200
committerotaj2022-10-24 16:28:51 +0200
commitd946c35ddae7cbdd86447562129b2a5d88b35d2f (patch)
treeb60b5f80753b6a402d463c0b7ef8bd4f653feb5a
parentd0eb59dbbb3c42b0071bb28aa4e27c771abf9020 (diff)
downloadaur-d946c35ddae7cbdd86447562129b2a5d88b35d2f.tar.gz
updpkg
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 21 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8722872bd7d..c9cdbb46b2c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-kornia
pkgdesc = Open Source Differentiable Computer Vision Library for PyTorch
- pkgver = 0.6.2
+ pkgver = 0.6.8
pkgrel = 1
url = https://github.com/kornia/kornia
arch = any
@@ -9,11 +9,15 @@ pkgbase = python-kornia
checkdepends = python-pytest-cov
checkdepends = python-pytest-mypy
checkdepends = python-pytest-flake8
- makedepends = python-setuptools
- makedepends = python-pip
+ checkdepends = python-scipy
+ checkdepends = python-opencv
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-pytest-runner
depends = python-pytorch
options = !emptydirs
- source = kornia-0.6.2.zip::https://github.com/kornia/kornia/archive/refs/tags/v0.6.2.zip
- sha256sums = f4aa4b5d7882bf8337269a3378dcd2f88f9a3704d36b4d08073a0c01f1f6ab9b
+ source = kornia-0.6.8.zip::https://github.com/kornia/kornia/archive/refs/tags/v0.6.8.zip
+ sha256sums = 61949be65328ee5da8562bc453c2989c009fab34ac57a430a8304d1834b5ba5e
pkgname = python-kornia
diff --git a/PKGBUILD b/PKGBUILD
index 2fd5dd5099cc..e46911f8d667 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,24 @@ TEST_GPU=0
pkgname=python-kornia
_name=kornia
-pkgver=0.6.2
+pkgver=0.6.8
pkgrel=1
arch=(any)
url='https://github.com/kornia/kornia'
pkgdesc='Open Source Differentiable Computer Vision Library for PyTorch'
license=(Apache)
-makedepends=('python-setuptools' 'python-pip')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-pytest-runner')
depends=('python-pytorch')
-checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-mypy' 'python-pytest-flake8')
+checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-mypy' 'python-pytest-flake8' 'python-scipy' 'python-opencv')
options=(!emptydirs)
# because kornia does not ship `pytest.ini` with their release, we have to get a fat copy of full repo
source=("${_name}-${pkgver}.zip::${url}/archive/refs/tags/v${pkgver}.zip")
-sha256sums=('f4aa4b5d7882bf8337269a3378dcd2f88f9a3704d36b4d08073a0c01f1f6ab9b')
+sha256sums=('61949be65328ee5da8562bc453c2989c009fab34ac57a430a8304d1834b5ba5e')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
check() {
cd "${srcdir}/${_name}-${pkgver}"
@@ -27,7 +32,7 @@ check() {
}
package() {
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1
- install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${srcdir}/${_name}-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}