summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Beringer2018-03-02 22:22:44 +0100
committerIan Beringer2018-03-02 22:47:46 +0100
commit3692a06d4592ef5f09ae15d450add75127e5a091 (patch)
tree8c1b9266c51acf2364bb7cebd465798abecb7e94
parentb931b9c7fadb77fab6876838494258315d4cd353 (diff)
downloadaur-3692a06d4592ef5f09ae15d450add75127e5a091.tar.gz
Update to 5.0.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD12
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f236064121e2..12b3edec94de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
pkgbase = python-kubernetes
pkgdesc = Python client for the kubernetes API
- pkgver = 2.0.0
+ pkgver = 5.0.0
pkgrel = 1
- url = https://github.com/kubernetes-incubator/client-python
+ url = https://github.com/kubernetes-client/python
arch = any
license = Apache
makedepends = python-setuptools
depends = python
- depends = python-websocket-client
- depends = python-urllib3
+ depends = python-certifi
depends = python-six
depends = python-dateutil
- depends = python-oauth2client
+ depends = python-urllib3
+ depends = python-yaml
+ depends = python-google-auth
depends = python-ipaddress
- depends = python-certifi
- source = https://github.com/kubernetes-incubator/client-python/archive/v2.0.0.tar.gz
- sha256sums = 12c3837c95e9e7237f1273712de6fbb4bec4172559e066a97f10edd281d0ad0c
+ depends = python-websocket-client
+ depends = python-requests
+ depends = python-requests-oauthlib
+ source = https://files.pythonhosted.org/packages/source/k/kubernetes/kubernetes-5.0.0.tar.gz
+ sha256sums = f81f145882471a1dd9d23360e99bd77027f07744729ef2728af4af7130cd19fd
pkgname = python-kubernetes
diff --git a/PKGBUILD b/PKGBUILD
index fde7615de9cc..e064d70adb93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Ian Beringer <ian@ianberinger.com>
pkgname=python-kubernetes
-_pkgname=client-python
-pkgver=2.0.0
+_pkgname=kubernetes
+pkgver=5.0.0
pkgrel=1
license=('Apache')
pkgdesc='Python client for the kubernetes API'
makedepends=('python-setuptools')
-depends=('python' 'python-websocket-client' 'python-urllib3' 'python-six' 'python-dateutil' 'python-oauth2client' 'python-ipaddress' 'python-certifi')
+depends=('python' 'python-certifi' 'python-six' 'python-dateutil' 'python-urllib3' 'python-yaml' 'python-google-auth' 'python-ipaddress' 'python-websocket-client' 'python-requests' 'python-requests-oauthlib')
arch=('any')
-url='https://github.com/kubernetes-incubator/client-python'
-source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('12c3837c95e9e7237f1273712de6fbb4bec4172559e066a97f10edd281d0ad0c')
+url='https://github.com/kubernetes-client/python'
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('f81f145882471a1dd9d23360e99bd77027f07744729ef2728af4af7130cd19fd')
package() {
cd "$srcdir/$_pkgname-$pkgver"