summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Beringer2018-08-23 11:16:01 +0200
committerIan Beringer2018-08-23 11:16:01 +0200
commit3f7e57d5073cd99c9d8c5e40d65ffcbb13c109ee (patch)
treed614de5354e0e9927b7556063e8bbcab616aef70
parent57cc59da9877071859c8b4cbc497d94cc9ef9c4b (diff)
downloadaur-3f7e57d5073cd99c9d8c5e40d65ffcbb13c109ee.tar.gz
Update to 7.0.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3fe23a2356b4..6d2113dddaf1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-kubernetes
pkgdesc = Python client for the kubernetes API
- pkgver = 6.0.0
+ pkgver = 7.0.0
pkgrel = 1
url = https://github.com/kubernetes-client/python
arch = any
@@ -17,8 +17,9 @@ pkgbase = python-kubernetes
depends = python-websocket-client
depends = python-requests
depends = python-requests-oauthlib
- source = https://files.pythonhosted.org/packages/source/k/kubernetes/kubernetes-6.0.0.tar.gz
- sha256sums = b370ab4abd925309db69a14a4723487948e9a83de60ca92782ec14992b741c89
+ depends = python-adal
+ source = https://files.pythonhosted.org/packages/source/k/kubernetes/kubernetes-7.0.0.tar.gz
+ sha256sums = 84dfb4319afac189e8327b71b9332b5329d2a78074f58958c5f06a870edf32ba
pkgname = python-kubernetes
diff --git a/PKGBUILD b/PKGBUILD
index 3f24bfa40730..ee631608333d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
pkgname=python-kubernetes
_pkgname=kubernetes
-pkgver=6.0.0
+pkgver=7.0.0
pkgrel=1
license=('Apache')
pkgdesc='Python client for the kubernetes API'
makedepends=('python-setuptools')
-depends=('python' 'python-certifi' 'python-six' 'python-dateutil' 'python-urllib3' 'python-yaml' 'python-google-auth' 'python-ipaddress' 'python-websocket-client' 'python-requests' 'python-requests-oauthlib')
+depends=('python' 'python-certifi' 'python-six' 'python-dateutil' 'python-urllib3' 'python-yaml' 'python-google-auth' 'python-ipaddress' 'python-websocket-client' 'python-requests' 'python-requests-oauthlib' 'python-adal')
arch=('any')
url='https://github.com/kubernetes-client/python'
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('b370ab4abd925309db69a14a4723487948e9a83de60ca92782ec14992b741c89')
+sha256sums=('84dfb4319afac189e8327b71b9332b5329d2a78074f58958c5f06a870edf32ba')
package() {
cd "$srcdir/$_pkgname-$pkgver"