summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Beringer2017-07-29 01:07:07 +0200
committerIan Beringer2017-07-29 01:07:07 +0200
commitb931b9c7fadb77fab6876838494258315d4cd353 (patch)
treecd0688a5f9cd0c6d7e9c3f6789e6a08361febe37
downloadaur-b931b9c7fadb77fab6876838494258315d4cd353.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD19
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f236064121e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-kubernetes
+ pkgdesc = Python client for the kubernetes API
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/kubernetes-incubator/client-python
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python
+ depends = python-websocket-client
+ depends = python-urllib3
+ depends = python-six
+ depends = python-dateutil
+ depends = python-oauth2client
+ depends = python-ipaddress
+ depends = python-certifi
+ source = https://github.com/kubernetes-incubator/client-python/archive/v2.0.0.tar.gz
+ sha256sums = 12c3837c95e9e7237f1273712de6fbb4bec4172559e066a97f10edd281d0ad0c
+
+pkgname = python-kubernetes
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fde7615de9cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Ian Beringer <ian@ianberinger.com>
+
+pkgname=python-kubernetes
+_pkgname=client-python
+pkgver=2.0.0
+pkgrel=1
+license=('Apache')
+pkgdesc='Python client for the kubernetes API'
+makedepends=('python-setuptools')
+depends=('python' 'python-websocket-client' 'python-urllib3' 'python-six' 'python-dateutil' 'python-oauth2client' 'python-ipaddress' 'python-certifi')
+arch=('any')
+url='https://github.com/kubernetes-incubator/client-python'
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('12c3837c95e9e7237f1273712de6fbb4bec4172559e066a97f10edd281d0ad0c')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}