summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoerg Behrmann2015-09-15 13:43:23 +0200
committerJoerg Behrmann2015-09-15 13:43:23 +0200
commit04c99363e3c19c88e09fab99c29eb23ebb9fbdc3 (patch)
tree47af73d817f5a60840160b1c84d80edef1fd6cb4
downloadaur-04c99363e3c19c88e09fab99c29eb23ebb9fbdc3.tar.gz
Initial commit
Reupload of python2-kwant package. Version has been updated to current release, python2-nose has been moved from optdepends to checkdepends and a check function has been added. The license field has been changed from custom to BSD to show the usage of a simplified BSD licsense (2-clause BSD).
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b5889bdadca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python2-kwant
+ pkgdesc = Python package for numerical calculations on tight-binding models with a strong focus on quantum transport
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = http://kwant-project.org/
+ arch = any
+ license = BSD
+ checkdepends = python2-nose
+ depends = python2
+ depends = python2-scipy
+ depends = lapack
+ depends = blas
+ depends = python2-tinyarray
+ optdepends = python2-matplotlib: needed for plotting support and the tutorial
+ optdepends = mumps: a sparse linear algebra library for speed up and memory usage reduction
+ source = http://downloads.kwant-project.org/kwant/kwant-1.0.4.tar.gz
+ source = http://downloads.kwant-project.org/kwant/kwant-1.0.4.tar.gz.asc
+ md5sums = 78c7c84c2d5fde2f8f24212b00447b78
+ md5sums = SKIP
+
+pkgname = python2-kwant
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be46d76b204f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Jörg Behrmann <behrmann@physik.fu-berlin.de>
+# Contributor: Max Schlemmer <max.schlemmer@gmail.com>
+pkgname=python2-kwant
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="Python package for numerical calculations on tight-binding models with a strong focus on quantum transport"
+arch=('any')
+url="http://kwant-project.org/"
+license=('BSD')
+depends=(python2 python2-scipy lapack blas python2-tinyarray)
+optdepends=(
+ 'python2-matplotlib: needed for plotting support and the tutorial'
+ 'mumps: a sparse linear algebra library for speed up and memory usage reduction'
+)
+checkdepends=(python2-nose)
+source=(
+ http://downloads.kwant-project.org/kwant/kwant-$pkgver.tar.gz
+ http://downloads.kwant-project.org/kwant/kwant-$pkgver.tar.gz.asc
+)
+md5sums=('78c7c84c2d5fde2f8f24212b00447b78'
+ 'SKIP')
+validpgpkeys=('52299057FAD799653C4F088AC3F147F5980F3535')
+
+build() {
+ cd "$srcdir/kwant-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/kwant-$pkgver"
+ python2 setup.py install --skip-build -O1 --root="$pkgdir" --optimize=1
+
+ # Install license
+ install -D -m644 "${srcdir}/kwant-${pkgver}/LICENSE.rst" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" || return 1
+}
+
+check() {
+ cd "$srcdir/kwant-$pkgver/kwant"
+ python2 -c 'import kwant; kwant.test()'
+}