summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoerg Behrmann2015-12-19 17:02:13 +0100
committerJoerg Behrmann2015-12-19 17:02:13 +0100
commit5fa87361802efe39682cb30441768c4f280f35ac (patch)
treef7806d8f231157d2f561a5a8f323ad01f01d1f3d
parentb8c3fc3adc2255ebce7acd10a652a2feab078755 (diff)
downloadaur-5fa87361802efe39682cb30441768c4f280f35ac.tar.gz
Update package to kwant 1.2.2 which requires python >=3.4
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD20
2 files changed, 23 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5900f5e2e8bb..d8f304a42cfc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,24 @@
-pkgbase = python2-kwant
+# Generated by mksrcinfo v8
+# Sat Dec 19 16:01:40 UTC 2015
+pkgbase = python-kwant
pkgdesc = Python package for numerical calculations on tight-binding models with a strong focus on quantum transport
- pkgver = 1.1.1
+ pkgver = 1.2.2
pkgrel = 1
url = http://kwant-project.org/
arch = any
license = BSD
- checkdepends = python2-nose
- depends = python2
- depends = python2-scipy
+ checkdepends = python-nose
+ depends = python
+ depends = python-scipy
depends = lapack
depends = blas
- depends = python2-tinyarray
- optdepends = python2-matplotlib: needed for plotting support and the tutorial
+ depends = python-tinyarray
+ optdepends = python-matplotlib: needed for plotting support and the tutorial
optdepends = mumps: a sparse linear algebra library for speed up and memory usage reduction
- source = http://downloads.kwant-project.org/kwant/kwant-1.1.1.tar.gz
- source = http://downloads.kwant-project.org/kwant/kwant-1.1.1.tar.gz.asc
- sha1sums = c6a76fc7e791f93632216ce40758d8622e5335f5
+ source = http://downloads.kwant-project.org/kwant/kwant-1.2.2.tar.gz
+ source = http://downloads.kwant-project.org/kwant/kwant-1.2.2.tar.gz.asc
+ sha1sums = 7a2aa07492c3aee8930fd7de402e62fea84f3eca
sha1sums = SKIP
-pkgname = python2-kwant
+pkgname = python-kwant
diff --git a/PKGBUILD b/PKGBUILD
index b3fa839b8fab..91d970a334bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,40 @@
# Maintainer: Jörg Behrmann <behrmann@physik.fu-berlin.de>
# Contributor: Max Schlemmer <max.schlemmer@gmail.com>
-pkgname=python2-kwant
-pkgver=1.1.1
+pkgname=python-kwant
+pkgver=1.2.2
pkgrel=1
pkgdesc="Python package for numerical calculations on tight-binding models with a strong focus on quantum transport"
arch=('any')
url="http://kwant-project.org/"
license=('BSD')
-depends=(python2 python2-scipy lapack blas python2-tinyarray)
+depends=(python python-scipy lapack blas python-tinyarray)
optdepends=(
- 'python2-matplotlib: needed for plotting support and the tutorial'
+ 'python-matplotlib: needed for plotting support and the tutorial'
'mumps: a sparse linear algebra library for speed up and memory usage reduction'
)
-checkdepends=(python2-nose)
+checkdepends=(python-nose)
source=(
http://downloads.kwant-project.org/kwant/kwant-$pkgver.tar.gz
http://downloads.kwant-project.org/kwant/kwant-$pkgver.tar.gz.asc
)
-sha1sums=('c6a76fc7e791f93632216ce40758d8622e5335f5'
+sha1sums=('7a2aa07492c3aee8930fd7de402e62fea84f3eca'
'SKIP')
validpgpkeys=('52299057FAD799653C4F088AC3F147F5980F3535')
build() {
cd "$srcdir/kwant-$pkgver"
- python2 setup.py build
+ python setup.py build
}
package() {
cd "$srcdir/kwant-$pkgver"
- python2 setup.py install --skip-build -O1 --root="$pkgdir" --optimize=1
+ python setup.py install --skip-build -O1 --root="$pkgdir" --optimize=1
# Install license
- install -D -m644 "${srcdir}/kwant-${pkgver}/LICENSE.rst" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" || return 1
+ install -D -m644 "${srcdir}/kwant-${pkgver}/LICENSE.rst" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.rst" || return 1
}
check() {
cd "$srcdir/kwant-$pkgver"
- python2 setup.py test
+ python setup.py test
}