summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoerg Behrmann2017-03-27 12:07:24 +0200
committerJoerg Behrmann2017-03-27 12:07:24 +0200
commit1d2d846800dd4e0cc825052adf2a7112b6e611b5 (patch)
tree468bcd407a412800d5163a0b903e6b5db4dea846
downloadaur-1d2d846800dd4e0cc825052adf2a7112b6e611b5.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD46
-rw-r--r--build.conf3
4 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee2dcd6f06ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-kwant-git
+ pkgdesc = Python package for numerical calculations on tight-binding models with a strong focus on quantum transport
+ pkgver = v1.3.0a0.r172.g3bb749e
+ pkgrel = 1
+ url = http://kwant-project.org/
+ arch = any
+ license = BSD
+ checkdepends = python-pytest
+ depends = python
+ depends = python-scipy
+ depends = lapack
+ depends = blas
+ depends = python-tinyarray-git
+ optdepends = python-matplotlib: needed for plotting support and the tutorial
+ optdepends = mumps: a sparse linear algebra library for speed up and memory usage reduction (use AUR mumps-seq-shared or any other built as shared library)
+ provides = python-kwant
+ conflicts = python-kwant
+ source = kwant::git+https://gitlab.kwant-project.org/kwant/kwant.git
+ source = build.conf
+ validpgpkeys = 52299057FAD799653C4F088AC3F147F5980F3535
+ sha256sums = SKIP
+ sha256sums = 32bef0aa0a6f329102c5244d856d4b50796c601b1d25e7c708e0e9bdf54425c7
+
+pkgname = python-kwant-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..386f3122833e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.xz
+*.tar.gz
+*.tar.gz.asc
+pkg/
+src/
+kwant/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7baec0860cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Jörg Behrmann <behrmann@physik.fu-berlin.de>
+pkgname=python-kwant-git
+pkgver=v1.3.0a0.r172.g3bb749e
+pkgrel=1
+pkgdesc="Python package for numerical calculations on tight-binding models with a strong focus on quantum transport"
+arch=('any')
+url="http://kwant-project.org/"
+license=('BSD')
+conflicts=('python-kwant')
+provides=('python-kwant')
+depends=(python python-scipy lapack blas python-tinyarray-git)
+optdepends=(
+ 'python-matplotlib: needed for plotting support and the tutorial'
+ 'mumps: a sparse linear algebra library for speed up and memory usage reduction (use AUR mumps-seq-shared or any other built as shared library)'
+)
+checkdepends=(python-pytest)
+source=('kwant::git+https://gitlab.kwant-project.org/kwant/kwant.git'
+ 'build.conf')
+sha256sums=('SKIP'
+ '32bef0aa0a6f329102c5244d856d4b50796c601b1d25e7c708e0e9bdf54425c7')
+validpgpkeys=('52299057FAD799653C4F088AC3F147F5980F3535')
+
+# Comment the prepare function if you want to build _without_ mumps support.
+# This is discouraged because without the incurred performance penalty no
+# serious calculations can be done in a reasonable time.
+prepare() {
+ cp "../build.conf" "$srcdir/kwant/build.conf"
+}
+
+build() {
+ cd "$srcdir/kwant"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/kwant"
+ python setup.py install --skip-build --root="$pkgdir"
+
+ # Install license
+ install -D -m644 "${srcdir}/kwant/LICENSE.rst" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.rst" || return 1
+}
+
+check() {
+ cd "$srcdir/kwant"
+ python setup.py test
+}
diff --git a/build.conf b/build.conf
new file mode 100644
index 000000000000..0cc107e1effa
--- /dev/null
+++ b/build.conf
@@ -0,0 +1,3 @@
+[mumps]
+libraries = zmumps mumps_common pord metis mpiseq gfortran
+include_dirs = /usr/include/mumps-seq-shared \ No newline at end of file