summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2023-05-10 17:12:35 +0800
committerYour Name2023-05-10 17:12:35 +0800
commit627b6f90e89dfceb88ddc2ec75ff5241d5d60db3 (patch)
treefb28ddcdac9d1b13e7bf2fac042ae5164b602bfe
parentb339265470639157092dd98952a65f9e9c785dd1 (diff)
downloadaur-627b6f90e89dfceb88ddc2ec75ff5241d5d60db3.tar.gz
update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c13ac77c2c1..58dbf28f7bb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = python-labmaze
pkgdesc = A standalone release of DeepMind Lab's maze generator with Python bindings
- pkgver = 1.0.5
+ pkgver = 1.0.6
pkgrel = 1
url = https://github.com/deepmind/labmaze
arch = x86_64
license = Apache-2.0
makedepends = python-setuptools
- makedepends = bazel
+ makedepends = bazel5
depends = python
depends = python-absl
depends = python-numpy
- source = https://github.com/deepmind/labmaze/archive/refs/tags/1.0.5.tar.gz
- source = fixbuild.patch
- sha256sums = 6f27748abb979f428cc2f6f2c18e51936791a9edf1fa78ff1850d106079eda05
- sha256sums = 051d8c0ed8ce05562976c182ec4c0c5921f589beb2bfcad2a6eb4fb20a579d1f
+ source = https://files.pythonhosted.org/packages/93/0a/139c4ae896b9413bd4ca69c62b08ee98dcfc78a9cbfdb7cadd0dce2ad31d/labmaze-1.0.6.tar.gz
+ sha256sums = 2e8de7094042a77d6972f1965cf5c9e8f971f1b34d225752f343190a825ebe73
pkgname = python-labmaze
diff --git a/PKGBUILD b/PKGBUILD
index a2360ec45699..9e60ff7805e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,17 @@
pkgname=python-labmaze
-pkgver=1.0.5
+pkgver=1.0.6
pkgrel=1
pkgdesc="A standalone release of DeepMind Lab's maze generator with Python bindings"
url="https://github.com/deepmind/labmaze"
license=("Apache-2.0")
arch=('x86_64')
depends=('python' 'python-absl' 'python-numpy')
-makedepends=('python-setuptools' 'bazel')
-source=("https://github.com/deepmind/labmaze/archive/refs/tags/$pkgver.tar.gz"
-"fixbuild.patch")
-sha256sums=('6f27748abb979f428cc2f6f2c18e51936791a9edf1fa78ff1850d106079eda05'
- '051d8c0ed8ce05562976c182ec4c0c5921f589beb2bfcad2a6eb4fb20a579d1f')
+makedepends=('python-setuptools' 'bazel5')
+source=("https://files.pythonhosted.org/packages/93/0a/139c4ae896b9413bd4ca69c62b08ee98dcfc78a9cbfdb7cadd0dce2ad31d/labmaze-1.0.6.tar.gz")
+sha256sums=('2e8de7094042a77d6972f1965cf5c9e8f971f1b34d225752f343190a825ebe73')
build() {
cd "${srcdir}/labmaze-$pkgver"
- patch -Np1 -i "${srcdir}/fixbuild.patch"
python setup.py build
}