summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2021-10-10 16:20:50 +0800
committerPumpkinCheshire2021-10-10 16:20:50 +0800
commit06570656a2e69584f4f1052c271b8348b56114c3 (patch)
tree9158f8c1e32ab8103ed5c57a4bd4764f91342a5a
parent5229ce85b76427863fe0157c129f56f6744a133a (diff)
downloadaur-06570656a2e69584f4f1052c271b8348b56114c3.tar.gz
bump to 3.2.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD29
2 files changed, 22 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f3063d571e3..fa31a5dba29c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = python-langcodes
pkgdesc = A toolkit for working with and comparing the standardized codes for languages
- pkgver = 3.1.0
+ pkgver = 3.2.1
pkgrel = 1
url = https://github.com/LuminosoInsight/langcodes
arch = any
license = Apache
makedepends = python
makedepends = python-setuptools
- source = https://files.pythonhosted.org/packages/source/l/langcodes/langcodes-3.1.0.tar.gz
+ source = https://files.pythonhosted.org/packages/source/l/langcodes/langcodes-3.2.1.tar.gz
source = https://raw.githubusercontent.com/LuminosoInsight/langcodes/master/LICENSE.txt
- sha256sums = 1ccd37e3a68760d29ec3b17f5962cd1d8f242f4d9705ad1601c5cb7fab48199c
- sha256sums = 84b11b945d88ab72e3790c5c2a0f8d0480f77d803bd810b5b149023bfce265af
+ b2sums = 2b82562a7f55e7bfb2d52203a46ee6dd12cd91ee4527268583f8da6b8c3c589ed17239bb4723e1a1d8604af766cf2de6997eae9c4f29333bf57bdc11d9a0229f
+ b2sums = afaae2fb675c7a953af2d251e57efa75ebe6278f5858c9f802bdec25490f589ba6f85df8d73377f302a8c6120314a479e97ce557315b9352c4d293fe84ba5435
pkgname = python-langcodes
-
diff --git a/PKGBUILD b/PKGBUILD
index 81e78582403e..63df126b5d7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,34 @@
-# Maintainer: PumpkinCheshire <sollyonzou@gmail.com>
+#!/bin/bash
+
+# Maintainer: PumpkinCheshire <me at pumpkincheshire dot top>
_name=langcodes
pkgname=python-langcodes
-pkgver=3.1.0
+pkgver=3.2.1
pkgrel=1
-pkgdesc="A toolkit for working with and comparing the standardized codes for languages"
+pkgdesc='A toolkit for working with and comparing the standardized codes for languages'
arch=('any')
url="https://github.com/LuminosoInsight/langcodes"
license=('Apache')
-makedepends=('python'
- 'python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/LuminosoInsight/langcodes/master/LICENSE.txt")
-sha256sums=('1ccd37e3a68760d29ec3b17f5962cd1d8f242f4d9705ad1601c5cb7fab48199c'
- '84b11b945d88ab72e3790c5c2a0f8d0480f77d803bd810b5b149023bfce265af')
+makedepends=(
+ 'python'
+ 'python-setuptools'
+)
+source=(
+ "https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/LuminosoInsight/langcodes/master/LICENSE.txt"
+)
+b2sums=('2b82562a7f55e7bfb2d52203a46ee6dd12cd91ee4527268583f8da6b8c3c589ed17239bb4723e1a1d8604af766cf2de6997eae9c4f29333bf57bdc11d9a0229f'
+ 'afaae2fb675c7a953af2d251e57efa75ebe6278f5858c9f802bdec25490f589ba6f85df8d73377f302a8c6120314a479e97ce557315b9352c4d293fe84ba5435')
build() {
- cd "$srcdir/$_name-$pkgver"
+ cd "$srcdir/$_name-$pkgver" || exit
+ export PYTHONHASHSEED=0
python setup.py build
}
package() {
- cd "$srcdir/$_name-$pkgver"
+ cd "$srcdir/$_name-$pkgver" || exit
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 "$srcdir/LICENSE.txt" -t "$pkgdir/usr/share/licenses/$pkgname"
}