summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRamon Buldó2015-06-08 16:01:11 +0200
committerRamon Buldó2015-06-08 16:01:11 +0200
commit9a4550198c82f7754ef71b7d841358c72de086b9 (patch)
tree16ab292ab6d20b19cdb8e0c30ed24b3ce559be35
downloadaur-9a4550198c82f7754ef71b7d841358c72de086b9.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..972eb15f0ae8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-langtable
+ pkgdesc = Guessing reasonable defaults for locale, keyboard layout, territory, and language.
+ pkgver = 0.0.33
+ pkgrel = 1
+ url = https://github.com/mike-fabian/langtable
+ arch = any
+ license = GPLv3+
+ license = MIT
+ depends = python
+ depends = python-setuptools
+ depends = gzip
+ options = !emptydirs
+ source = https://github.com/mike-fabian/langtable/archive/0.0.33.tar.gz
+ sha256sums = 26c9a5891c3a92995b49bfc3e32d87b66eb089dd30e1c7cda4aa44347196b363
+
+pkgname = python-langtable
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbb998f576dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Kirek <rbuldo at gmail dot com>
+pkgname=python-langtable
+_pyname=langtable
+pkgver=0.0.33
+pkgrel=1
+pkgdesc='Guessing reasonable defaults for locale, keyboard layout, territory, and language.'
+arch=('any')
+url='https://github.com/mike-fabian/langtable'
+license=('GPLv3+' 'MIT')
+depends=('python' 'python-setuptools' 'gzip')
+options=(!emptydirs)
+source=("https://github.com/mike-fabian/${_pyname}/archive/${pkgver}.tar.gz")
+sha256sums=('26c9a5891c3a92995b49bfc3e32d87b66eb089dd30e1c7cda4aa44347196b363')
+
+_destdir=/usr
+_datadir=${_destdir}/share/langtable
+
+build () {
+ cd "${srcdir}/${_pyname}-${pkgver}"
+ python setup.py build
+}
+package() {
+ cd "${srcdir}/${_pyname}-${pkgver}"
+ python setup.py install --prefix="${_destdir}" --root="${pkgdir}" --install-data="${_datadir}" --optimize=1 --skip-build
+ gzip --force --best ${pkgdir}/${_datadir}/*.xml
+}