summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspecter1192019-04-13 15:17:23 +0800
committerspecter1192019-04-13 15:17:23 +0800
commitaa5142d2cda473c3655176d7a58f699a1b177022 (patch)
treef59b415ab3fe2bcc8bff9031f2f6aca8b430df46
downloadaur-aa5142d2cda473c3655176d7a58f699a1b177022.tar.gz
init commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bbce66b9420e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-language-tags
+ pkgdesc = Dealing with IANA language tags in Python.
+ pkgver = 0.4.6
+ pkgrel = 1
+ url = https://pypi.org/project/language-tags
+ arch = any
+ license = MIT
+ depends = python-six
+ source = https://files.pythonhosted.org/packages/source/l/language_tags/language_tags-0.4.6.tar.gz
+ source = https://raw.githubusercontent.com/OnroerendErfgoed/language-tags/master/LICENSE
+ md5sums = bff3d91f77be9c5ec587e54efafc859e
+ md5sums = SKIP
+
+pkgname = python-language-tags
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca360e83101c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Ke Liu <spcter119@gmail.com>
+
+pkgname=python-language-tags
+pkgver=0.4.6
+pkgrel=1
+pkgdesc='Dealing with IANA language tags in Python.'
+arch=('any')
+url='https://pypi.org/project/language-tags'
+license=('MIT')
+depends=('python-six')
+_pkgname=language_tags
+source=("https://files.pythonhosted.org/packages/source/l/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/OnroerendErfgoed/language-tags/master/LICENSE")
+md5sums=('bff3d91f77be9c5ec587e54efafc859e'
+ 'SKIP')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py clean --all
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root "$pkgdir"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}