summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-01-09 12:31:21 -0600
committerLuis Martinez2022-01-09 12:31:21 -0600
commit4ca08e8ece92eea7e024bb7c6f7674498419064b (patch)
treeb7afb7842603afac53b8dc2ec1773595c095893e
parent083f4d50e9bb0fc08afb3e969b3ae5d06a9d2189 (diff)
downloadaur-4ca08e8ece92eea7e024bb7c6f7674498419064b.tar.gz
update to 2.1.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md87
-rw-r--r--PKGBUILD23
3 files changed, 106 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b8882b8045e..16c73ca86de0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = python-laspy
pkgdesc = Pythonic interface for .LAS LIDAR files
- pkgver = 2.0.3
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/laspy/laspy
+ changelog = CHANGELOG.md
arch = any
license = custom
makedepends = git
+ makedepends = python-m2r2
makedepends = python-setuptools
makedepends = python-sphinx
makedepends = python-sphinx_rtd_theme
depends = python-numpy
- source = python-laspy-2.0.3::git+https://github.com/laspy/laspy#commit=4438f472de74e44df45309c84feb517f7538ed09?signed
+ source = python-laspy::git+https://github.com/laspy/laspy#commit=af790d5?signed
validpgpkeys = 44B238524D21C5064D7081BD5022EF94BE848C51
sha256sums = SKIP
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..82605a32213a
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,87 @@
+# Changelog
+
+## 2.1.0
+
+### Added
+- Added a better error message when reading empty files
+- Added a new `xyz` attribute to `LasData` that returns x, y, z as a new numpy array or sets the x, y, z from an array
+- Added `LasData.remove_extra_dim` and `LasData.remove_extra_dims` to allow the removal of extra dimensions (__only__)
+
+### Changed
+- Minimum `lazrs` version updated to 0.4.0 to bring support for LAZ with variable size chunks
+ (used in [COPC](https://copc.io) files). the `laszip` backend already supported variable size chunks LAZ.
+- Improved assigning to multiple dimensions at once (`las[['x', 'y', 'z']] = ...`)
+- `laspy` will no longer raise encoding errors when reading files for which the header's `generating_software` or
+ `system_identifier` as well as the vlr's `description` is not `ascii` encoded as the spec mandates.
+ However, an encoding error will be raised when writing such files.
+- `LasData.__getitem__` will now return a `LasData` when indexing with slice or numpy array.
+ `assert isinstance(las[[1, 2, 3, 4]], laspy.LasData)`
+
+### Fixed
+- Fix `PackedPointRecord.__len__` when array has no dim
+- Fix scaled extra byte creation when the offsets/scales given to `ExtraBytesParam` where of type `list` or `tuple`
+- Fix `ScaledArrayView` to allow indexing with `list` or `numpy.array`.
+
+## Version 2.0.3
+
+## Fixed
+- Fix function that parses geotiff VLRs
+- Fix handling of points with 'unregistered' extra bytes (PR #158)
+- Fix to handle empty LAS/LAZ more robustly
+
+## Version 2.0.2
+
+### Changed
+- Update minimum lazrs version which allows to:
+ - Fix Appending in LAZ files.
+ - Improve memory usage when reading/writing. (issue #152)
+
+### Fixed
+- Fix system_identifier reading by ignoring non ascii characters instead of erroring ,(issue #148, PR #149).
+- Fix `LasData.change_scaling` method.
+
+## Version 2.0.1
+
+### Fixed
+- Fix `.min` `.max` methods of array views
+- Ship the tests as part of the source distribution (But they won't be installed with `pip install`)
+
+## Version 2.0.0
+
+- Overhaul of the internals by essentially incorporating pylas into laspy,
+ while the API to retrieve and set dimensions stayed the same, other parts changed
+ and will require adaptation.
+- Better LAZ support
+ * Added support for writing LAZ
+ * Changed decompression mechanism by using either `laszip` python bindings (and not laszip-cli)
+ or `lazrs`
+- Added ability to read and write LAS/LAS in `stream` / `chunked` mode.
+- Changed laspy to support the reading and writing of LAS/LAZ data from and to `file-objects` and `bytes`
+- Dropped support for python2.7, python3.6+ is supported.
+
+---
+
+## Version 1.7.0
+
+- Fixed bug in point record format 5, 9 and 10 [#105](https://github.com/laspy/laspy/issues/105)
+- Return explicit msg if laszip executable was not found [#110](https://github.com/laspy/laspy/issues/110)
+- Supprt numpy 1.17 [#122](https://github.com/laspy/laspy/issues/122)
+
+## Version 1.6.0
+
+- Bug fix [#92](https://github.com/laspy/laspy/issues/92)
+- Test creation of all valid custom dimension data types
+- Modify handling of extra bytes to be char data instead of numeric byte data
+
+## Version 1.5.1
+
+- Bug fixes [#67](https://github.com/laspy/laspy/pull/67), [#75](https://github.com/laspy/laspy/pull/75), [b02b40900b5](https://github.com/laspy/laspy/commit/b02b40900b5620972930cd0c201b4db1a6a69754)
+- Allow usage of `laszip-cli` when working with LAZ files [#77](https://github.com/laspy/laspy/pull/77)
+
+## Version 1.5.0
+
+- Improved memory handling in base.FileManager [#48](https://github.com/laspy/laspy/pull/48)
+- Introduced `r-` file mode, that only reads the header of as LAS file [#48](https://github.com/laspy/laspy/pull/48)
+- LAS v. 1.4 bug fixes [#55](https://github.com/laspy/laspy/pull/55)
+- Python 3 support [#62](https://github.com/laspy/laspy/pull/62)
+
diff --git a/PKGBUILD b/PKGBUILD
index df3d1a6f1a1d..6d70cfc07d03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,31 +4,38 @@
pkgname=python-laspy
pkgdesc="Pythonic interface for .LAS LIDAR files"
url="https://github.com/laspy/laspy"
-pkgver=2.0.3
-_commit=4438f472de74e44df45309c84feb517f7538ed09
+pkgver=2.1.0
+_commit=af790d5
pkgrel=1
arch=('any')
license=('custom')
depends=('python-numpy')
-makedepends=('git' 'python-setuptools' 'python-sphinx' 'python-sphinx_rtd_theme')
-source=("$pkgname-$pkgver::git+$url#commit=$_commit?signed")
+makedepends=(
+ 'git'
+ 'python-m2r2'
+ 'python-setuptools'
+ 'python-sphinx'
+ 'python-sphinx_rtd_theme')
+changelog=CHANGELOG.md
+source=("$pkgname::git+$url#commit=$_commit?signed")
sha256sums=('SKIP')
validpgpkeys=('44B238524D21C5064D7081BD5022EF94BE848C51')
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
python setup.py build
cd docs
PYTHONPATH=../ make man
}
package() {
- cd "$pkgname-$pkgver"
+ export PYTHONHASHSEED=0
+ cd "$pkgname"
python setup.py install \
--prefix=/usr \
--root="$pkgdir" \
--optimize=1 \
--skip-build
- install -Dm 644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm 644 docs/_build/man/laspy.1 -t "$pkgdir/usr/share/man/man1/"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 docs/_build/man/laspy.1 -t "$pkgdir/usr/share/man/man1/"
}