summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-02-04 11:39:38 -0600
committerLuis Martinez2022-02-04 11:39:38 -0600
commit554278697f45e58ac35b9ccffc5002d7eb3a0e23 (patch)
treedc525492b8c4796a60ec21c753481beaf085b6c9
parent4ca08e8ece92eea7e024bb7c6f7674498419064b (diff)
downloadaur-554278697f45e58ac35b9ccffc5002d7eb3a0e23.tar.gz
update to 2.1.1
-rw-r--r--.SRCINFO7
-rw-r--r--CHANGELOG.md11
-rw-r--r--PKGBUILD15
3 files changed, 23 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16c73ca86de0..478841a64867 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-laspy
pkgdesc = Pythonic interface for .LAS LIDAR files
- pkgver = 2.1.0
+ pkgver = 2.1.1
pkgrel = 1
url = https://github.com/laspy/laspy
changelog = CHANGELOG.md
@@ -9,10 +9,13 @@ pkgbase = python-laspy
makedepends = git
makedepends = python-m2r2
makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-install
+ makedepends = python-wheel
makedepends = python-sphinx
makedepends = python-sphinx_rtd_theme
depends = python-numpy
- source = python-laspy::git+https://github.com/laspy/laspy#commit=af790d5?signed
+ source = python-laspy::git+https://github.com/laspy/laspy#commit=d5d4361?signed
validpgpkeys = 44B238524D21C5064D7081BD5022EF94BE848C51
sha256sums = SKIP
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 82605a32213a..6dff431a6dad 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,16 @@
# Changelog
+## Unreleased
+
+## 2.1.1
+
+### Fixed
+- Fixed regression introduced in 2.1.0 where setting the x, y or z value would not properly set the corresponding
+ X, Y or Z value.
+- Fixed `LasData.change_scaling` setting the header's `offsets` and/or `scales` to `None`
+ if the corresponding optionnal argument was not given to the `change_scaling` method.
+ The header will now correctly keep the corresponding value unchanged.
+
## 2.1.0
### Added
diff --git a/PKGBUILD b/PKGBUILD
index 6d70cfc07d03..a44802143408 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=python-laspy
pkgdesc="Pythonic interface for .LAS LIDAR files"
url="https://github.com/laspy/laspy"
-pkgver=2.1.0
-_commit=af790d5
+pkgver=2.1.1
+_commit=d5d4361
pkgrel=1
arch=('any')
license=('custom')
@@ -14,6 +14,9 @@ makedepends=(
'git'
'python-m2r2'
'python-setuptools'
+ 'python-build'
+ 'python-install'
+ 'python-wheel'
'python-sphinx'
'python-sphinx_rtd_theme')
changelog=CHANGELOG.md
@@ -23,7 +26,7 @@ validpgpkeys=('44B238524D21C5064D7081BD5022EF94BE848C51')
build() {
cd "$pkgname"
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
cd docs
PYTHONPATH=../ make man
}
@@ -31,11 +34,7 @@ build() {
package() {
export PYTHONHASHSEED=0
cd "$pkgname"
- python setup.py install \
- --prefix=/usr \
- --root="$pkgdir" \
- --optimize=1 \
- --skip-build
+ python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 docs/_build/man/laspy.1 -t "$pkgdir/usr/share/man/man1/"
}