summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2023-07-24 19:01:00 +0200
committerBlair Bonnett2023-07-24 19:01:00 +0200
commitc107db6dd8be81eef38909c44610c3f1ccc2f788 (patch)
tree3f7bf60a30d6261861b25b4eaf6962cb62d14367
parentc7979efb9e5cf8e651d6772c714afcaadb27cc7e (diff)
downloadaur-c107db6dd8be81eef38909c44610c3f1ccc2f788.tar.gz
Update to 2.5.0
-rw-r--r--.SRCINFO4
-rw-r--r--CHANGELOG.md23
-rw-r--r--PKGBUILD4
3 files changed, 27 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81d64a6409d6..4c291350c587 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-laspy
pkgdesc = Pythonic interface for .LAS LIDAR files
- pkgver = 2.4.1
+ pkgver = 2.5.0
pkgrel = 1
url = https://github.com/laspy/laspy
changelog = CHANGELOG.md
@@ -19,7 +19,7 @@ pkgbase = python-laspy
optdepends = python-laszip: LAZ support
optdepends = python-pyproj: CRS support
optdepends = python-requests: COPC support over HTTPS
- source = git+https://github.com/laspy/laspy#commit=a72e3b122?signed
+ source = git+https://github.com/laspy/laspy#commit=5cd7ac624?signed
source = modify_doc_conf.patch
validpgpkeys = 44B238524D21C5064D7081BD5022EF94BE848C51
sha256sums = SKIP
diff --git a/CHANGELOG.md b/CHANGELOG.md
index dce05091060d..a98efa72b724 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,28 @@
# Changelog
+## 2.5.0
+
+### Added
+- Added optional CLI. It has `info`, `compress`, `decompress`,
+`convert` and `copc query` commands.
+- Added a `prefer_wkt` option to `LasHeader.parse_crs`
+(true by default) to prefer (or not) WKT VLR over Geotiff VLR
+in case both are present in the file.
+
+### Fixed
+- laspy.open will now properly close the opened file
+if an exception is raised.
+- Wavepackets's `return_point_wave_location` is now
+properly returned as as float32 and not an uint32.
+- `parse_crs` properly checks that ProjectedCRSGeoKey/GeodeticCRSGeoKey
+is in range of EPSG code before using pyproj to parse it.
+- Missing `super.__init__()` in `CopcHierarchyVlr`.
+- Copc no longer include the hierarchy page twice
+- A LasHeader with a custom `creation_date`/`date` will
+no longer be reset to `date.today` upon writing.
+
+---
+
## 2.4.1
### Fixed
diff --git a/PKGBUILD b/PKGBUILD
index 8248a7033bc8..896d9ce30f94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=python-laspy
pkgdesc="Pythonic interface for .LAS LIDAR files"
url="https://github.com/laspy/laspy"
-pkgver=2.4.1
+pkgver=2.5.0
pkgrel=1
arch=('any')
license=('BSD')
@@ -30,7 +30,7 @@ makedepends=(
checkdepends=('python-pytest')
_pyname=laspy
-_commit=a72e3b122
+_commit=5cd7ac624
source=(
"git+$url#commit=$_commit?signed"
'modify_doc_conf.patch'