summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-07-01 16:51:30 -0500
committerLuis Martinez2022-07-01 16:51:30 -0500
commitfcae2080489e3f1c809fbeec463239cafa746f5a (patch)
tree67c83016db9bbe00fddebbc31c4aaaa85fc85f94
parentdda4384ca8bc86a4e292521a9b1444b7e8a35771 (diff)
downloadaur-fcae2080489e3f1c809fbeec463239cafa746f5a.tar.gz
update to 2.2.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md51
-rw-r--r--PKGBUILD21
3 files changed, 65 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b843780622b3..f639f0ae67c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = python-laspy
pkgdesc = Pythonic interface for .LAS LIDAR files
- pkgver = 2.1.2
+ pkgver = 2.2.0
pkgrel = 1
url = https://github.com/laspy/laspy
changelog = CHANGELOG.md
arch = any
- license = custom
+ license = BSD
makedepends = git
makedepends = python-m2r2
makedepends = python-setuptools
@@ -15,7 +15,7 @@ pkgbase = python-laspy
makedepends = python-sphinx
makedepends = python-sphinx_rtd_theme
depends = python-numpy
- source = python-laspy::git+https://github.com/laspy/laspy#commit=d5d4361?signed
+ source = python-laspy::git+https://github.com/laspy/laspy#commit=fbb2973?signed
validpgpkeys = 44B238524D21C5064D7081BD5022EF94BE848C51
sha256sums = SKIP
diff --git a/CHANGELOG.md b/CHANGELOG.md
index b6b9190529c6..91b12e8f287f 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,12 +1,51 @@
# Changelog
+## 2.2.0
+
+### Added
+- Added support for querying COPC LAZ files via a new class `CopcReader`.
+- Added new optional feature to support adding CRS / SRS to a LAS file from a `pyproj.CRS` as
+ well as reading the CRS / SRS information from a LAS file to a `pyproj.CRS`.
+
+### Fixed
+- Fixed support for stream / source that are not `seekable`.
+
+### Changed
+- Support for Python3.6 removed.
+
+---
+
+## 2.2.0 beta 1
+
+### Added
+- Added support for querying COPC LAZ files via a new class `CopcReader`.
+
+### Fixed
+- Fixed support for stream / source that are not `seekable`.
+
+---
+
+## 2.2.0 beta 0
+
+### Added
+- Added new optional feature to support adding CRS / SRS to a LAS file from a `pyproj.CRS` as
+ well as reading the CRS / SRS information from a LAS file to a `pyproj.CRS`.
+
+### Changed
+- Support for Python3.6 removed.
+
+---
+
## 2.1.2
+
### Fixed
- Fixed `LasHeader.update` (thus fixing `LasData.update_header`) computation of x,y,z mins and maxs
- Fixed regression introduced in 2.1.0 where changing the `header.scales` and/or `header.offsets`
on a `LasData` newly created and then setting `x` `y` or `z` would produce incorrect result.
+---
+
## 2.1.1
### Fixed
@@ -16,6 +55,8 @@
if the corresponding optionnal argument was not given to the `change_scaling` method.
The header will now correctly keep the corresponding value unchanged.
+---
+
## 2.1.0
### Added
@@ -38,6 +79,8 @@
- Fix scaled extra byte creation when the offsets/scales given to `ExtraBytesParam` where of type `list` or `tuple`
- Fix `ScaledArrayView` to allow indexing with `list` or `numpy.array`.
+---
+
## Version 2.0.3
## Fixed
@@ -45,6 +88,8 @@
- Fix handling of points with 'unregistered' extra bytes (PR #158)
- Fix to handle empty LAS/LAZ more robustly
+---
+
## Version 2.0.2
### Changed
@@ -53,15 +98,19 @@
- Improve memory usage when reading/writing. (issue #152)
### Fixed
-- Fix system_identifier reading by ignoring non ascii characters instead of erroring ,(issue #148, PR #149).
+- Fix `system_identifier` reading by ignoring non ascii characters instead of erroring ,(issue #148, PR #149).
- Fix `LasData.change_scaling` method.
+---
+
## Version 2.0.1
### Fixed
- Fix `.min` `.max` methods of array views
- Ship the tests as part of the source distribution (But they won't be installed with `pip install`)
+---
+
## Version 2.0.0
- Overhaul of the internals by essentially incorporating pylas into laspy,
diff --git a/PKGBUILD b/PKGBUILD
index 2a074d9be681..f4f19c2f23e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
# Contributor: Kuan-Yen Chou <kuanyenchou at gmail dot com>
pkgname=python-laspy
+_pkg="${pkgname#python-}"
pkgdesc="Pythonic interface for .LAS LIDAR files"
url="https://github.com/laspy/laspy"
-pkgver=2.1.2
-_commit=d5d4361
+pkgver=2.2.0
+_commit=fbb2973
pkgrel=1
arch=('any')
-license=('custom')
+license=('BSD')
depends=('python-numpy')
makedepends=(
'git'
@@ -26,15 +27,17 @@ validpgpkeys=('44B238524D21C5064D7081BD5022EF94BE848C51')
build() {
cd "$pkgname"
- python -m build --wheel --skip-dependency-check --no-isolation
- cd docs
- PYTHONPATH=../ make man
+ python -m build --wheel --no-isolation
+ PYTHONPATH="$PWD" make -C docs man
}
package() {
- export PYTHONHASHSEED=0
cd "$pkgname"
- python -m installer --destdir="$pkgdir/" dist/*.whl
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 docs/_build/man/laspy.1 -t "$pkgdir/usr/share/man/man1/"
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s \
+ "$_site/$_pkg-$pkgver.dist-info/LICENSE.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}