summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuliette Monsel2019-02-19 17:53:20 +0100
committerJuliette Monsel2019-02-19 17:53:20 +0100
commitcbd37c1a1f621e331f8ea49224c5d343ffc47f80 (patch)
tree62cb304e110d3c9f8a7ae0f65a4813fcf124f716
downloadaur-cbd37c1a1f621e331f8ea49224c5d343ffc47f80.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD30
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4bf52175d53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-launchpadlib
+ pkgdesc = A free Python 3 library for scripting Launchpad through its web services interface.
+ pkgver = 1.10.6
+ pkgrel = 1
+ url = https://launchpad.net/launchpadlib
+ arch = any
+ license = LGPL3
+ makedepends = python-setuptools
+ depends = python-lazr-uri
+ depends = python-lazr-restfulclient
+ depends = python-wadllib
+ depends = python-keyring
+ depends = python-httplib2
+ depends = python-simplejson
+ optdepends = python-setuptools
+ optdepends = python-testresources
+ source = python-launchpadlib-1.10.6.tar.gz::https://launchpad.net/launchpadlib/trunk/1.10.6/+download/launchpadlib-1.10.6.tar.gz
+ source = python-launchpadlib-1.10.6.tar.gz.asc::https://launchpad.net/launchpadlib/trunk/1.10.6/+download/launchpadlib-1.10.6.tar.gz.asc
+ validpgpkeys = AC0A4FF12611B6FCCF01C111393587D97D86500B
+ sha256sums = e4709c18214863d147c6e0415e695d5cfddefc0dbd6ea28eb03e6eada956ae8b
+ sha256sums = SKIP
+
+pkgname = python-launchpadlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4f5958b5136
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Juliette Monsel <j_4321 at protonmail dot com>
+# based on the python2-launchpadlib PKGBUILD by ValHue <vhuelamo at gmail dot com>
+
+_pkgname="launchpadlib"
+pkgname=("python-launchpadlib")
+pkgver="1.10.6"
+pkgrel="1"
+pkgdesc="A free Python 3 library for scripting Launchpad through its web services interface."
+arch=('any')
+url="https://launchpad.net/launchpadlib"
+license=('LGPL3')
+makedepends=('python-setuptools')
+depends=('python-lazr-uri' 'python-lazr-restfulclient' 'python-wadllib'
+ 'python-keyring' 'python-httplib2' 'python-simplejson')
+optdepends=('python-setuptools' 'python-testresources')
+source=("${pkgname}-${pkgver}.tar.gz::https://launchpad.net/$_pkgname/trunk/$pkgver/+download/$_pkgname-$pkgver.tar.gz"
+ "${pkgname}-${pkgver}.tar.gz.asc::https://launchpad.net/$_pkgname/trunk/$pkgver/+download/$_pkgname-$pkgver.tar.gz.asc")
+sha256sums=('e4709c18214863d147c6e0415e695d5cfddefc0dbd6ea28eb03e6eada956ae8b'
+ 'SKIP')
+validpgpkeys=('AC0A4FF12611B6FCCF01C111393587D97D86500B')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package_python-launchpadlib() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}