summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuliette Monsel2019-02-19 17:45:55 +0100
committerJuliette Monsel2019-02-19 17:45:55 +0100
commit06e06bd2784a8eedb0bed15097a44ab8447839b6 (patch)
tree678edabb06f38479ef5672ec789ba41f6140d874
downloadaur-06e06bd2784a8eedb0bed15097a44ab8447839b6.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed20a7c0bb48
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-lazr-uri
+ pkgdesc = A self-contained, easily reusable library for parsing, manipulating, and generating URIs.
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://launchpad.net/lazr.uri
+ arch = any
+ license = LGPL3
+ makedepends = python-setuptools
+ depends = python-setuptools
+ source = python-lazr-uri-1.0.3.tar.gz::https://launchpad.net/lazr.uri/trunk/1.0.3/+download/lazr.uri-1.0.3.tar.gz
+ sha256sums = 5c620b5993c8c6a73084176bfc51de64972b8373620476ed841931a49752dc8b
+
+pkgname = python-lazr-uri
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15f5a17e1611
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Juliette Monsel <j_4321 at protonmail dot com>
+# based on the python2-lazr-uri PKGBUILD by ValHue <vhuelamo at gmail dot com>
+
+_pkgname="lazr.uri"
+pkgname=("python-lazr-uri")
+pkgver="1.0.3"
+pkgrel="1"
+pkgdesc="A self-contained, easily reusable library for parsing, manipulating, and generating URIs."
+arch=('any')
+url="https://launchpad.net/$_pkgname"
+license=('LGPL3')
+makedepends=('python-setuptools')
+depends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::https://launchpad.net/$_pkgname/trunk/$pkgver/+download/$_pkgname-$pkgver.tar.gz")
+sha256sums=('5c620b5993c8c6a73084176bfc51de64972b8373620476ed841931a49752dc8b')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}