summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-03-04 09:22:20 +0300
committerCaleb Maclennan2020-03-04 09:22:20 +0300
commit9409ce14d83c3373510a17bf72036ee90f344a8e (patch)
tree9c42edbcaa94c6ca1ded4d267c32391d257e859d
parent7c7bda8faa4d74ee8221ccc2f870de908d46585e (diff)
downloadaur-9409ce14d83c3373510a17bf72036ee90f344a8e.tar.gz
Split build() and package() stages, add check() stage
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD33
2 files changed, 25 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2beb9234f224..9180dc210a04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-leather
- pkgdesc = Python charting for 80% of humans.
+ pkgdesc = Python charting for 80% of humans
pkgver = 0.3.3
- pkgrel = 1
+ pkgrel = 2
url = https://leather.readthedocs.io/
arch = any
license = MIT
makedepends = python-setuptools
depends = python
depends = python-six
- source = https://github.com/wireservice/leather/archive/0.3.3.tar.gz
+ source = leather-0.3.3.tar.gz::https://github.com/wireservice/leather/archive/0.3.3.tar.gz
sha256sums = 70f621f7c5ddac6bc3261850134c0187cb200844243eb878a29f8a8f15a8db46
pkgname = python-leather
diff --git a/PKGBUILD b/PKGBUILD
index 1b0ede2288bb..c36958b7cc4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,31 @@
# Maintainer: Michał Pałubicki <maln0ir@gmx.com>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
_pkgname=leather
pkgname=python-$_pkgname
pkgver=0.3.3
-pkgrel=1
-pkgdesc="Python charting for 80% of humans."
-arch=("any")
-url="https://leather.readthedocs.io/"
-license=("MIT")
-depends=("python"
- "python-six")
-makedepends=("python-setuptools")
-source=("https://github.com/wireservice/leather/archive/${pkgver}.tar.gz")
+pkgrel=2
+pkgdesc='Python charting for 80% of humans'
+arch=('any')
+url='https://leather.readthedocs.io/'
+license=('MIT')
+depends=('python'
+ 'python-six')
+makedepends=('python-setuptools')
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/wireservice/$_pkgname/archive/$pkgver.tar.gz")
sha256sums=('70f621f7c5ddac6bc3261850134c0187cb200844243eb878a29f8a8f15a8db46')
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+check() {
+ cd "$_pkgname-$pkgver"
+ python setup.py test --test-suite=tests
+}
+
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}