summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjiakai2023-08-08 15:41:45 -0400
committerjiakai2023-08-08 15:41:45 -0400
commit853c4164abd03f584c25f7568815e67e3e89879d (patch)
treecff915ae00831160bc751fe9d785657a0e309c3b
parent29fda2355edb442cbdeee710df2cf913c3dc6e93 (diff)
downloadaur-853c4164abd03f584c25f7568815e67e3e89879d.tar.gz
update to 1.13.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--fix-test-np-import.patch12
3 files changed, 6 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42664e769d13..5c95f8ba527a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-lensfunpy
pkgdesc = Python wrapper for the lensfun library
- pkgver = 1.13.0
+ pkgver = 1.13.1
pkgrel = 1
url = https://github.com/letmaik/lensfunpy
arch = x86_64
@@ -19,9 +19,7 @@ pkgbase = python-lensfunpy
depends = python-numpy
optdepends = python-scikit-image
optdepends = python-opencv
- source = python-lensfunpy-1.13.0.tar.gz::https://github.com/letmaik/lensfunpy/archive/v1.13.0.tar.gz
- source = fix-test-np-import.patch
- sha512sums = 2ce5cda73b6be0efdd6543d467b959aababdd3fcbc37c5075f5d5109c2274a26894cf298fd4826158fd1eecfccb5b6b1b9cda64efe663655a078ed2ef4e102bd
- sha512sums = 4eabf53dddbc9d09fe4dd984170992170a9cfa656ee5eff638c6f6bdce2b8d5abc5cf8ea9d2e20408879cb6357d2f438729940e542d38a3462370409e50b890f
+ source = python-lensfunpy-1.13.1.tar.gz::https://github.com/letmaik/lensfunpy/archive/v1.13.1.tar.gz
+ sha512sums = fec57f7141ee7be9a462e9b4f02a670d85e7eee2258fcf02836364da522d95e7b900df7fb495f53e1919536c2defb3a49432ab95f44c04fdb7b277d93c6104fc
pkgname = python-lensfunpy
diff --git a/PKGBUILD b/PKGBUILD
index 11b54cba7160..bc1d80bd0f7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-lensfunpy
_pkg="${pkgname#python-}"
-pkgver=1.13.0
+pkgver=1.13.1
pkgrel=1
pkgdesc="Python wrapper for the lensfun library"
arch=('x86_64')
@@ -19,16 +19,9 @@ makedepends=(
'python-sphinx_rtd_theme'
'python-wheel')
checkdepends=('python-pytest' 'python-imageio' 'python-scikit-image')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
- "fix-test-np-import.patch")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha512sums=(
- '2ce5cda73b6be0efdd6543d467b959aababdd3fcbc37c5075f5d5109c2274a26894cf298fd4826158fd1eecfccb5b6b1b9cda64efe663655a078ed2ef4e102bd'
- '4eabf53dddbc9d09fe4dd984170992170a9cfa656ee5eff638c6f6bdce2b8d5abc5cf8ea9d2e20408879cb6357d2f438729940e542d38a3462370409e50b890f')
-
-prepare() {
- patch --directory="$_pkg-$pkgver" --forward --strip=1 \
- --input="${srcdir}/fix-test-np-import.patch"
-}
+ 'fec57f7141ee7be9a462e9b4f02a670d85e7eee2258fcf02836364da522d95e7b900df7fb495f53e1919536c2defb3a49432ab95f44c04fdb7b277d93c6104fc')
build() {
cd "$_pkg-$pkgver"
diff --git a/fix-test-np-import.patch b/fix-test-np-import.patch
deleted file mode 100644
index 1ee8d33623e1..000000000000
--- a/fix-test-np-import.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --color --unified --recursive --text lensfunpy-1.13.0.orig/test/test_basic.py lensfunpy-1.13.0.new/test/test_basic.py
---- lensfunpy-1.13.0.orig/test/test_basic.py 2023-02-26 13:43:47.000000000 -0500
-+++ lensfunpy-1.13.0.new/test/test_basic.py 2023-07-24 11:54:06.732806854 -0400
-@@ -1,7 +1,7 @@
- import numpy as np
- import lensfunpy as lensfun
- import gc
--from numpy.testing.utils import assert_equal
-+from numpy.testing import assert_equal
-
- # the following strings were taken from the lensfun xml files
- cam_maker = 'NIKON CORPORATION'