summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Lipp2015-06-15 20:18:56 +0200
committerMoritz Lipp2015-06-15 20:18:56 +0200
commit165179ba58fbde77d1cb042bf9ebce624bc6cb3e (patch)
tree94c32b4b5a392b2028108bdf5d8a5f5f1cd258ce
downloadaur-165179ba58fbde77d1cb042bf9ebce624bc6cb3e.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
3 files changed, 61 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..5c1d3f21bb06
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = python-libfiu
+ pkgdesc = userspace fault injection framework
+ pkgver = 0.93
+ pkgrel = 1
+ url = https://blitiri.com.ar/p/libfiu/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = make
+ makedepends = gcc
+ depends = libfiu
+ depends = python
+ source = https://blitiri.com.ar/p/libfiu/files/0.93/libfiu-0.93.tar.gz
+
+pkgname = python-libfiu
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f783792b1ec9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-libfiu
+ pkgdesc = userspace fault injection framework
+ pkgver = 0.93
+ pkgrel = 1
+ url = https://blitiri.com.ar/p/libfiu/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = make
+ makedepends = gcc
+ depends = libfiu
+ depends = python
+ source = https://blitiri.com.ar/p/libfiu/files/0.93/libfiu-0.93.tar.gz
+ md5sums = 8d8126a05a0fd7e833544c6a73deb256
+
+pkgname = python-libfiu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b5855c07c08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Moritz Lipp <mlq@pwmt.org>
+
+pkgname=python-libfiu
+_pkgname=libfiu
+pkgver=0.93
+pkgrel=1
+pkgdesc="userspace fault injection framework"
+arch=('i686' 'x86_64')
+url="https://blitiri.com.ar/p/libfiu/"
+license=('custom')
+depends=('libfiu' 'python')
+makedepends=('make' 'gcc')
+source=("https://blitiri.com.ar/p/$_pkgname/files/$pkgver/$_pkgname-$pkgver.tar.gz")
+md5sums=('8d8126a05a0fd7e833544c6a73deb256')
+
+build() {
+ cd $srcdir/$_pkgname-$pkgver/bindings/python
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver/bindings/python
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ # Install LICENSE
+ cd $srcdir/$_pkgname-$pkgver
+ install -D -m664 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}