summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2018-02-28 00:28:37 -0500
committerbrent s2018-02-28 00:28:37 -0500
commitf9a07aaf4fcc792954a655507aa627c514be2a71 (patch)
tree6f5efb7f0d76c3d09195be1f6def0298903d2ccb
parentef63e863caa0c48e65b1bf1f8ae87e3054760632 (diff)
downloadaur-f9a07aaf4fcc792954a655507aa627c514be2a71.tar.gz
proper build
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 23 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88d4213ea418..00aeeeab6531 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
-# Generated by aurpkgs
-# Wed Feb 28 05:26:55 UTC 2018
+# Generated by mksrcinfo v8
+# Wed Feb 28 05:28:37 UTC 2018
pkgbase = python-libguestfs
pkgdesc = Python bindings for libguestfs
pkgver = 1.38.0
- pkgrel = 1
+ pkgrel = 2
url = http://libguestfs.org/
- arch = i686
- arch = x86_64
+ arch = any
license = LGPL3
- depends = python
- depends = libguestfs
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ makedepends = libguestfs
source = http://download.libguestfs.org/python/guestfs-1.38.0.tar.gz
source = guestfs-1.38.0.tar.gz.sig
sha512sums = 35aa80c6889fd11aeac364436e6dfe5199b5a9771937085a45c9cc1d6943559cd33fda7e28d62f54ba06e10b5f0f8e462dc94d35621c7da3bc82467f60d988cd
sha512sums = SKIP
pkgname = python-libguestfs
+ depends = python
+ depends = libguestfs
+
diff --git a/PKGBUILD b/PKGBUILD
index fa03f7ee85d8..98b3c2957ce5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,23 @@
-# Maintainer: brent s. <bts[at]square-r00t[dot]net>
validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
# News updates for packages can be followed at https://devblog.square-r00t.net
pkgname=python-libguestfs
pkgver=1.38.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python bindings for libguestfs"
-arch=( 'i686' 'x86_64' )
+arch=('any')
url="http://libguestfs.org/"
-license=( 'LGPL3' )
-depends=( 'python' 'libguestfs' )
-_pkgname=python-libguestfs
-install=
-changelog=
-noextract=()
-source=("http://download.libguestfs.org/python/guestfs-1.38.0.tar.gz"
- "guestfs-1.38.0.tar.gz.sig")
+license=('LGPL3')
+_pkgname=guestfs
+makedepends=('python-setuptools' 'python2-setuptools' 'libguestfs')
+source=("http://download.libguestfs.org/python/${_pkgname}-${pkgver}.tar.gz"
+ "${_pkgname}-${pkgver}.tar.gz.sig")
sha512sums=('35aa80c6889fd11aeac364436e6dfe5199b5a9771937085a45c9cc1d6943559cd33fda7e28d62f54ba06e10b5f0f8e462dc94d35621c7da3bc82467f60d988cd'
'SKIP')
-build() {
- cd "${srcdir}/${_pkgname}/src"
- make prefix=${pkgdir}/usr
-}
-package() {
- install -D -m755 ${srcdir}/${_pkgname}/src/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
- install -D -m644 ${srcdir}/${_pkgname}/docs/README.html.en ${pkgdir}/usr/share/doc/${_pkgname}/README.html
+
+package_python-libguestfs() {
+ depends=('python' 'libguestfs')
+
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
}