summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsomini2020-04-21 00:37:32 +0100
committersomini2020-04-21 00:37:32 +0100
commit9d4d74003a6478cbcd922b7d87b9e95e20647aec (patch)
tree5aeedcbb95f69e81e9554afa3d63c7d86b28dbf0
downloadaur-9d4d74003a6478cbcd922b7d87b9e95e20647aec.tar.gz
Initial Import
Used pip2pkgbuild
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f5ba5a9ea81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-libinput
+ pkgdesc = Object-oriented wrapper for libinput using ctypes
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/OzymandiasTheGreat/python-libinput
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/p/python-libinput/python-libinput-0.1.0.tar.gz
+ sha256sums = e6b20e7fd889001fe74b01a1ff456e5f53c9ed01b016d6ceb65b6f573f129758
+
+pkgname = python-libinput
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ba7822d168fd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa4c94001ae3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: somini <dev@somini.xyz>
+
+pkgbase=python-libinput
+pkgname=python-libinput
+_module='python-libinput'
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Object-oriented wrapper for libinput using ctypes"
+url="https://github.com/OzymandiasTheGreat/python-libinput"
+depends=('python')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('e6b20e7fd889001fe74b01a1ff456e5f53c9ed01b016d6ceb65b6f573f129758')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}