summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsomini2020-04-21 01:54:31 +0100
committersomini2020-04-21 01:54:31 +0100
commitd626fb5a112419f7f1e146336dee9bf5ede7fbfb (patch)
tree22bdd876baa20ab36e3175591f42cd660520a1c0
parenta8d19347868d382d0d5d00802de28638e044a8ec (diff)
downloadaur-d626fb5a112419f7f1e146336dee9bf5ede7fbfb.tar.gz
Update to a pre-release version of 0.3.0
This is technically the current master, but I tested and it works for me...
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10d4c15d1c89..0ea89f39a7a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = python-libinput
pkgdesc = Object-oriented wrapper for libinput using ctypes
- pkgver = 0.1.0
- pkgrel = 2
+ pkgver = 0.3.0pre1
+ pkgrel = 1
url = https://github.com/OzymandiasTheGreat/python-libinput
arch = any
license = MIT
makedepends = python-setuptools
depends = python
depends = libinput
- source = https://files.pythonhosted.org/packages/source/p/python-libinput/python-libinput-0.1.0.tar.gz
- sha256sums = e6b20e7fd889001fe74b01a1ff456e5f53c9ed01b016d6ceb65b6f573f129758
+ source = python-libinput-0.3.0pre1.tar.gz::https://github.com/OzymandiasTheGreat/python-libinput/archive/1f477ee9f1d56b284b20e0317ea8967c64ef1218.tar.gz
+ sha256sums = d3b3f8d70cf43ca74bd15abc449eecf91a5d2111360e1911ff193ee5856aaeb4
pkgname = python-libinput
diff --git a/PKGBUILD b/PKGBUILD
index 2e190e875893..fbba36e82a8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,28 @@
pkgbase=python-libinput
pkgname=python-libinput
_module='python-libinput'
-pkgver=0.1.0
-pkgrel=2
+pkgver=0.3.0pre1
+# TODO: remove
+_commit=1f477ee9f1d56b284b20e0317ea8967c64ef1218
+pkgrel=1
pkgdesc="Object-oriented wrapper for libinput using ctypes"
url="https://github.com/OzymandiasTheGreat/python-libinput"
depends=('python' 'libinput')
makedepends=('python-setuptools')
license=('MIT')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('e6b20e7fd889001fe74b01a1ff456e5f53c9ed01b016d6ceb65b6f573f129758')
+# TODO: revert
+source=("$_module-$pkgver.tar.gz::https://github.com/OzymandiasTheGreat/python-libinput/archive/$_commit.tar.gz")
+sha256sums=('d3b3f8d70cf43ca74bd15abc449eecf91a5d2111360e1911ff193ee5856aaeb4')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ # TODO: revert
+ cd "${srcdir}/${_module}-$_commit"
python setup.py build
}
package() {
- cd "${srcdir}/${_module}-${pkgver}"
+ # TODO: revert
+ cd "${srcdir}/${_module}-$_commit"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}