summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrançois Boulogne2015-06-09 21:53:13 -0400
committerFrançois Boulogne2015-06-09 21:53:13 -0400
commita5d5f9f856c621087977b74288495d594b6cbba5 (patch)
tree00e1e77d2759312456845b6d0ad00d76da25fc5b
downloadaur-a5d5f9f856c621087977b74288495d594b6cbba5.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c445610dbd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-liblarch-git
+ pkgdesc = Python library to easily handle data structure, with a GTK binding
+ pkgver = v0.1.r114.g3ea294a
+ pkgrel = 2
+ url = https://wiki.gnome.org/action/show/Projects/liblarch
+ arch = any
+ license = LGPL3
+ checkdepends = python-nose
+ makedepends = git
+ makedepends = python
+ makedepends = python-distribute
+ depends = python
+ depends = python-gobject
+ provides = python-liblarch
+ conflicts = python-liblarch
+ source = git://github.com/liblarch/liblarch.git
+ md5sums = SKIP
+
+pkgname = python-liblarch-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e13597288750
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor: Francois Boulogne <fboulogne at april dot org>
+# Maintainer: Francois Boulogne <fboulogne at april dot org>
+pkgname=python-liblarch-git
+pkgver=v0.1.r114.g3ea294a
+pkgrel=2
+pkgdesc="Python library to easily handle data structure, with a GTK binding"
+arch=('any')
+url="https://wiki.gnome.org/action/show/Projects/liblarch"
+license=('LGPL3')
+depends=('python' 'python-gobject')
+optdepends=()
+makedepends=('git' 'python' 'python-distribute')
+checkdepends=('python-nose')
+provides=('python-liblarch')
+conflicts=('python-liblarch')
+source=("git://github.com/liblarch/liblarch.git")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/liblarch"
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+check() {
+ cd "$srcdir/liblarch"
+ python run-tests
+}
+
+build() {
+
+ cd "$srcdir/liblarch"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/liblarch"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: