summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquininer2022-09-17 18:04:00 +0800
committerquininer2022-09-17 18:04:00 +0800
commit4631cc23e8dc23a7100a53700bbb91a74cd11026 (patch)
treedceac9aa9426538a58b5f1f81aec2b7b3e412706
downloadaur-4631cc23e8dc23a7100a53700bbb91a74cd11026.tar.gz
init
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD31
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0dfb78fc947c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-libnxctrl-git
+ pkgdesc = Python Library Emulating Nintendo Switch Controllers
+ pkgver = 0.1.7.e3ed8bc
+ pkgrel = 1
+ url = https://github.com/Victrid/libnxctrl
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = dbus-python
+ depends = python-flask
+ depends = python-flask-socketio
+ depends = python-eventlet
+ depends = python-blessed
+ depends = python-pynput
+ depends = python-psutil
+ depends = python-cryptography
+ depends = python-hid
+ depends = python-aioconsole
+ provides = python-libnxctrl
+ conflicts = python-libnxctrl
+ source = python-libnxctrl::git+https://github.com/Victrid/libnxctrl.git
+ sha256sums = SKIP
+
+pkgname = python-libnxctrl-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c1d6d769860
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=python-libnxctrl-git
+_pkgname="python-libnxctrl"
+pkgdesc="Python Library Emulating Nintendo Switch Controllers"
+pkgver=0.1.7.e3ed8bc
+pkgrel=1
+arch=('i686' 'x86_64')
+conflicts=($_pkgname)
+provides=($_pkgname)
+url="https://github.com/Victrid/libnxctrl"
+license=('GPL3')
+depends=(
+ "dbus-python" "python-flask" "python-flask-socketio" "python-eventlet"
+ "python-blessed" "python-pynput" "python-psutil" "python-cryptography"
+ "python-hid" "python-aioconsole"
+)
+optdepends=()
+makedepends=('git')
+source=("$_pkgname::git+https://github.com/Victrid/libnxctrl.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "%s.%s" "$(python setup.py --version)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $_pkgname
+ git submodule update --init --recursive --depth 1
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}