summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2022-01-26 10:16:15 +0800
committerPumpkinCheshire2022-01-26 10:16:15 +0800
commit302852dc3215d53cc3084fb9a2941eeefe9e3fae (patch)
tree035c099213f90eb9af404f2b3c9a9a4774389cb7
parentf48af586d6abfc8259cb425cc133010bb0dae65f (diff)
downloadaur-302852dc3215d53cc3084fb9a2941eeefe9e3fae.tar.gz
bump to 4.6.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ff4231840d2..06d4c60a253f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-libpysal
pkgdesc = Core components of Python Spatial Analysis Library.
- pkgver = 4.5.1
+ pkgver = 4.6.0
pkgrel = 1
url = https://pysal.org/libpysal/
arch = any
@@ -40,7 +40,7 @@ pkgbase = python-libpysal
optdepends = python-xarray: plus conda
optdepends = python-black: dev tool
optdepends = python-pre-commit: dev tool
- source = https://files.pythonhosted.org/packages/source/l/libpysal/libpysal-4.5.1.tar.gz
- b2sums = 8353f5043c008b1c7fcfaf0a13304b7fd811e439857d9b0f348de3809d836e599d089b7ebce568ebb8c381961ab6f274d233ede064a75d635b0a54320cfc5f64
+ source = https://files.pythonhosted.org/packages/source/l/libpysal/libpysal-4.6.0.tar.gz
+ b2sums = 39c615ee86d7e344db104c2b11b8aac3ac03b7bde80be9b48f5dbdc6f92f14f6ce187d39b39226ab5f564156a66b80afc9b29e02a243c60c65964fc147dfb389
pkgname = python-libpysal
diff --git a/PKGBUILD b/PKGBUILD
index e2f06d0d700f..93945896e9db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,20 @@
_name=libpysal
pkgname=python-libpysal
-pkgver=4.5.1
+pkgver=4.6.0
pkgrel=1
pkgdesc="Core components of Python Spatial Analysis Library."
arch=('any')
url="https://pysal.org/libpysal/"
license=('BSD')
-depends=('python-beautifulsoup4' 'python-jinja' 'python-numpy' 'python-pandas' 'python-requests' 'python-scipy')
+depends=(
+ 'python-beautifulsoup4'
+ 'python-jinja'
+ 'python-numpy'
+ 'python-pandas'
+ 'python-requests'
+ 'python-scipy'
+)
optdepends=(
'python-pypandoc: documents'
'python-nbsphinx: documents'
@@ -41,7 +48,7 @@ optdepends=(
)
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-b2sums=('8353f5043c008b1c7fcfaf0a13304b7fd811e439857d9b0f348de3809d836e599d089b7ebce568ebb8c381961ab6f274d233ede064a75d635b0a54320cfc5f64')
+b2sums=('39c615ee86d7e344db104c2b11b8aac3ac03b7bde80be9b48f5dbdc6f92f14f6ce187d39b39226ab5f564156a66b80afc9b29e02a243c60c65964fc147dfb389')
build() {
cd "$_name-$pkgver"