summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-06 14:13:09 -0700
committerMark Wagie2024-01-06 14:13:09 -0700
commit51884b1d395d981dca38eee1c4d623eb775e06e4 (patch)
treedd10f2a1283f39786034973ae135934fc6026846
parent5901e6896ec7ae9dadebbd4e909baf490061b7d9 (diff)
downloadaur-python-libsass.tar.gz
0.23.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
2 files changed, 23 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b816252f1be..6bf3da21be1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-libsass
pkgdesc = Sass for Python: A straightforward binding of libsass for Python.
- pkgver = 0.22.0
- pkgrel = 2
+ pkgver = 0.23.0
+ pkgrel = 1
url = https://sass.github.io/libsass-python/
arch = x86_64
arch = aarch64
@@ -16,7 +16,7 @@ pkgbase = python-libsass
depends = libsass
depends = python-setuptools
provides = _sass.abi3.so
- source = git+https://github.com/sass/libsass-python.git#commit=b18db090672676d7c58fcd52e6ae0eb505993886
+ source = git+https://github.com/sass/libsass-python.git#commit=af3c4bf4ab0b852447fc2b2f46001e499c615011
sha256sums = SKIP
pkgname = python-libsass
diff --git a/PKGBUILD b/PKGBUILD
index 22f1d21f281b..e390bd021d02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,42 @@
# Maintainer: Mark Wagie <mark at proton dot me>
pkgname=python-libsass
_name=${pkgname#python-}
-pkgver=0.22.0
-pkgrel=2
+pkgver=0.23.0
+pkgrel=1
pkgdesc="Sass for Python: A straightforward binding of libsass for Python."
arch=('x86_64' 'aarch64')
url="https://sass.github.io/libsass-python/"
license=('MIT')
depends=('libsass' 'python-setuptools')
makedepends=('git' 'python-build' 'python-installer' 'python-wheel')
+#makedepends+=('python-sphinx') # needed for docs
provides=('_sass.abi3.so')
checkdepends=('python-pip' 'python-pytest' 'python-werkzeug')
-_commit=b18db090672676d7c58fcd52e6ae0eb505993886 # tags/0.22.0^0
+_commit=af3c4bf4ab0b852447fc2b2f46001e499c615011 # tags/0.23.0^0
source=("git+https://github.com/sass/libsass-python.git#commit=$_commit")
sha256sums=('SKIP')
+pkgver() {
+ cd "$_name-python"
+ git describe --tags | sed 's/-/+/g'
+}
+
build() {
- cd "$srcdir/$_name-python"
+ cd "$_name-python"
export SYSTEM_SASS="1"
python -m build --wheel --no-isolation
+
+# pushd docs
+ # There are differences between Python's naming of architectures and the
+ # ${CARCH} variable. We need to ask Python for the platform name
+# local PLATFORM=$(python -c "import sysconfig; print(sysconfig.get_platform())")
+# export PYTHONPATH=$(echo ../build/lib.${PLATFORM}-*)
+# make man
+# popd
}
check() {
- cd "$srcdir/$_name-python"
+ cd "$_name-python"
local PLATFORM=$(python -c "import sysconfig; print(sysconfig.get_platform())")
local python_version=$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
export PYTHONPATH=build/lib.${PLATFORM}-cpython-${python_version//./}
@@ -30,7 +44,7 @@ check() {
}
package() {
- cd "$srcdir/$_name-python"
+ cd "$_name-python"
export SYSTEM_SASS="1"
python -m installer --destdir="$pkgdir" dist/*.whl